Bulletin d'alerte Debian

DSA-415-1 zebra -- Déni de service

Date du rapport :
6 janvier 2004
Paquets concernés :
zebra
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans la base de données de suivi des bogues (chez SecurityFocus) : Identifiant BugTraq 9029.
Dans le dictionnaire CVE du Mitre : CVE-2003-0795, CVE-2003-0858.
Plus de précisions :

Deux vulnérabilités ont été découvertes dans zebra, un démon de routage IP :

  • CAN-2003-0795 - un bogue dans l'interface de commande telnet peut permettre à un attaquant distant de faire planter le processus zebra, causant un déni de service ;
  • CAN-2003-0858 - les messages Netlink envoyés par d'autres utilisateurs (plutôt que par le noyau) seraient acceptés, ce qui causerait un déni de service.

Pour la distribution stable actuelle (Woody), ce problème a été corrigé dans la version 0.92a-5woody2.

Le paquet zebra a été retiré de la distribution instable, il est remplacé par GNU Quagga, pour lequel ce problème a été corrigé dans la version 0.96.4x-4.

Nous vous recommandons de mettre votre paquet zebra à jour.

Corrigé dans :

Debian GNU/Linux 3.0 (woody)

Source :
http://security.debian.org/pool/updates/main/z/zebra/zebra_0.92a-5woody2.dsc
http://security.debian.org/pool/updates/main/z/zebra/zebra_0.92a-5woody2.diff.gz
http://security.debian.org/pool/updates/main/z/zebra/zebra_0.92a.orig.tar.gz
Composant indépendant de l'architecture :
http://security.debian.org/pool/updates/main/z/zebra/zebra-doc_0.92a-5woody2_all.deb
Alpha:
http://security.debian.org/pool/updates/main/z/zebra/zebra_0.92a-5woody2_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/z/zebra/zebra_0.92a-5woody2_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/z/zebra/zebra_0.92a-5woody2_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/z/zebra/zebra_0.92a-5woody2_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/z/zebra/zebra_0.92a-5woody2_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/z/zebra/zebra_0.92a-5woody2_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/z/zebra/zebra_0.92a-5woody2_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/z/zebra/zebra_0.92a-5woody2_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/z/zebra/zebra_0.92a-5woody2_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/z/zebra/zebra_0.92a-5woody2_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/z/zebra/zebra_0.92a-5woody2_sparc.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.