Debian セキュリティ勧告

DSA-473-1 oftpd -- サービス不能 (DoS) 攻撃

報告日時:
2004-04-03
影響を受けるパッケージ:
oftpd
危険性:
あり
参考セキュリティデータベース:
Debian バグ追跡システム: バグ 216871.
(SecurityFocus の) Bugtraq データベース: BugTraq ID 9980.
Mitre の CVE 辞書: CVE-2004-0376.
詳細:

匿名 ftp サーバ用パッケージである oftpd に、PORT コマンドに大きな値を与えることでリモートの攻撃者が oftpd をクラッシュさせることができるという欠陥が発見されました。

安定版 (stable) ディストリビューション (woody) では、この問題はバージョン 0.3.6-6 で修正されています。

不安定版 (unstable) ディストリビューション (sid) では、この問題はバージョン 20040304-1 で修正されています。

直ちに oftpd パッケージをアップグレードすることをお勧めします。

修正:

Debian GNU/Linux 3.0 (woody)

ソース:
http://security.debian.org/pool/updates/main/o/oftpd/oftpd_0.3.6-6.dsc
http://security.debian.org/pool/updates/main/o/oftpd/oftpd_0.3.6-6.diff.gz
http://security.debian.org/pool/updates/main/o/oftpd/oftpd_0.3.6.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/o/oftpd/oftpd_0.3.6-6_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/o/oftpd/oftpd_0.3.6-6_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/o/oftpd/oftpd_0.3.6-6_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/o/oftpd/oftpd_0.3.6-6_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/o/oftpd/oftpd_0.3.6-6_hppa.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/o/oftpd/oftpd_0.3.6-6_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/o/oftpd/oftpd_0.3.6-6_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/o/oftpd/oftpd_0.3.6-6_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/o/oftpd/oftpd_0.3.6-6_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/o/oftpd/oftpd_0.3.6-6_sparc.deb

一覧にあるファイルの MD5 チェックサムは勧告の原文にあります。