Debian-Sicherheitsankündigung

DSA-512-1 gallery -- Unberechtigter Zugriff

Datum des Berichts:
02. Jun 2004
Betroffene Pakete:
gallery
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In der Bugtraq-Datenbank (bei SecurityFocus): BugTraq ID 10451.
In Mitres CVE-Verzeichnis: CVE-2004-0522.
Weitere Informationen:

Eine Verwundbarkeit wurde in gallery entdeckt, einem in PHP geschriebenen webbasierten Fotoalbum, wodurch ein entfernter Angreifer Zugriff auf den gallery »admin«-Benutzer ohne korrekte Authentifizierung erlangen könnte. Zum Zeitpunkt der Veröffentlichung war kein CVE-Kandidat für diese Verwundbarkeit verfügbar.

Für die aktuelle stable Distribution (Woody) wurden diese Probleme in Version 1.2.5-8woody2 behoben.

Für die unstable Distribution (Sid) wurden diese Probleme in Version 1.4.3-pl2-1 behoben.

Wir empfehlen Ihnen, Ihr gallery-Paket zu aktualisieren.

Behoben in:

Debian GNU/Linux 3.0 (woody)

Quellcode:
http://security.debian.org/pool/updates/main/g/gallery/gallery_1.2.5-8woody2.dsc
http://security.debian.org/pool/updates/main/g/gallery/gallery_1.2.5-8woody2.diff.gz
http://security.debian.org/pool/updates/main/g/gallery/gallery_1.2.5.orig.tar.gz
Architektur-unabhängige Dateien:
http://security.debian.org/pool/updates/main/g/gallery/gallery_1.2.5-8woody2_all.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.