Säkerhetsbulletin från Debian

DSA-512-1 gallery -- oautentiserad åtkomst

Rapporterat den:
2004-06-02
Berörda paket:
gallery
Sårbara:
Ja
Referenser i säkerhetsdatabaser:
I Bugtraq-databasen (hos SecurityFocus): BugTraq-id 10451.
I Mitres CVE-förteckning: CVE-2004-0522.
Ytterligare information:

En sårbarhet har upptäckts i gallery, ett webbaserat fotoalbum skrivet i php, med vilken en angripare utifrån kunde få tillgång till gallerys ”admin”-användare utan ordentlig autentisering. Det fanns inte någon CVE-kandidat för denna sårbarhet när denna bulletin publicerades.

För den nuvarande stabila utgåvan (Woody) har dessa problem rättats i version 1.2.5-8woody2.

För den instabila utgåvan (Sid) har dessa problem rättats i version 1.4.3-pl2-1.

Vi rekommenderar att ni uppgraderar ert gallery-paket.

Rättat i:

Debian GNU/Linux 3.0 (woody)

Källkod:
http://security.debian.org/pool/updates/main/g/gallery/gallery_1.2.5-8woody2.dsc
http://security.debian.org/pool/updates/main/g/gallery/gallery_1.2.5-8woody2.diff.gz
http://security.debian.org/pool/updates/main/g/gallery/gallery_1.2.5.orig.tar.gz
Arkitekturoberoende komponent:
http://security.debian.org/pool/updates/main/g/gallery/gallery_1.2.5-8woody2_all.deb

MD5-kontrollsummor för dessa filer finns i originalbulletinen.