Debian-Sicherheitsankündigung

DSA-530-1 l2tpd -- Pufferüberlauf

Datum des Berichts:
17. Jul 2004
Betroffene Pakete:
l2tpd
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In Mitres CVE-Verzeichnis: CVE-2004-0649.
Weitere Informationen:

Thomas Walpuski meldete einen Pufferüberlauf in l2tpd, einer Implementierung des Layer-2-Tunneling-Protokolls, wodurch ein entfernter Angreifer potenziell beliebigen Code ausführen lassen kann, indem er ein speziell präpariertes Paket überträgt. Ob diese Verwundbarkeit ausnutzbar ist, wurde noch nicht überprüft.

Für die aktuelle Stable-Distribution (Woody) wurde dieses Problem in Version 0.67-1.2 behoben.

Für die Unstable-Distribution (Sid) wurde dieses Problem in Version 0.70-pre20031121-2 behoben.

Wir empfehlen Ihnen, Ihr l2tpd-Paket zu aktualisieren.

Behoben in:

Debian GNU/Linux 3.0 (woody)

Quellcode:
http://security.debian.org/pool/updates/main/l/l2tpd/l2tpd_0.67-1.2.dsc
http://security.debian.org/pool/updates/main/l/l2tpd/l2tpd_0.67-1.2.diff.gz
http://security.debian.org/pool/updates/main/l/l2tpd/l2tpd_0.67.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/l/l2tpd/l2tpd_0.67-1.1_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/l/l2tpd/l2tpd_0.67-1.2_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/l/l2tpd/l2tpd_0.67-1.2_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/l/l2tpd/l2tpd_0.67-1.2_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/l/l2tpd/l2tpd_0.67-1.2_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/l/l2tpd/l2tpd_0.67-1.2_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/l/l2tpd/l2tpd_0.67-1.2_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/l/l2tpd/l2tpd_0.67-1.2_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/l/l2tpd/l2tpd_0.67-1.2_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/l/l2tpd/l2tpd_0.67-1.2_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/l/l2tpd/l2tpd_0.67-1.2_sparc.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.