Aviso de seguridad de Debian

DSA-534-1 mailreader -- travesía por directorio

Fecha del informe:
22 de jul de 2004
Paquetes afectados:
mailreader
Vulnerable:
Referencias a bases de datos de seguridad:
En la base de datos de Bugtraq (en SecurityFocus): Id. en BugTraq 6055.
En el diccionario CVE de Mitre: CVE-2002-1581.
Información adicional:

Se descubrió una vulnerabilidad de travesía por directorio en mailreader, por medio de la cual los atacantes podían ver archivos arbitrarios con los privilegios del proceso nph-mr.cgi (de forma predefinida, www-data) por medio de rutas relativas y un byte nulo en el parámetro configLanguage.

Para la distribución estable (woody), este problema se ha corregido en la versión 2.3.29-5woody1.

Para la distribución inestable (sid), este problema se corregirá en breve.

Le recomendamos que actualice el paquete mailreader.

Arreglado en:

Debian GNU/Linux 3.0 (woody)

Fuentes:
http://security.debian.org/pool/updates/main/m/mailreader/mailreader_2.3.29-5woody1.dsc
http://security.debian.org/pool/updates/main/m/mailreader/mailreader_2.3.29-5woody1.diff.gz
http://security.debian.org/pool/updates/main/m/mailreader/mailreader_2.3.29.orig.tar.gz
Componentes independientes de la arquitectura:
http://security.debian.org/pool/updates/main/m/mailreader/mailreader_2.3.29-5woody1_all.deb

Las sumas MD5 de los ficheros que se listan están disponibles en el aviso original.