Debians sikkerhedsbulletin

DSA-553-1 getmail -- symlink-sårbarhed

Rapporteret den:
27. sep 2004
Berørte pakker:
getmail
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 272561.
I Mitres CVE-ordbog: CVE-2004-0880, CVE-2004-0881.
Yderligere oplysninger:

Et sikkerhedsproblem er opdaget i getmail, et POP3- og APOP-program til indsamling og videresendelse af e-mail. En angriber med en shell-konto på offerets værtsmaskine kunne udnytte getmail til at overskrive vilkårlige filer når programmet kørte som root.

I den stabile distribution (woody) er dette problem rettet i version 2.3.7-2.

I den ustabile distribution (sid) er dette problem rettet i version 3.2.5-1.

Vi anbefaler at du opgraderer din getmail-pakke.

Rettet i:

Debian GNU/Linux 3.0 (woody)

Kildekode:
http://security.debian.org/pool/updates/main/g/getmail/getmail_2.3.7-2.dsc
http://security.debian.org/pool/updates/main/g/getmail/getmail_2.3.7-2.diff.gz
http://security.debian.org/pool/updates/main/g/getmail/getmail_2.3.7.orig.tar.gz
Arkitekturuafhængig komponent:
http://security.debian.org/pool/updates/main/g/getmail/getmail_2.3.7-2_all.deb

MD5-kontrolsummer for de listede filer findes i den originale sikkerhedsbulletin.