Debian-Sicherheitsankündigung

DSA-553-1 getmail -- Symlink-Verwundbarkeit

Datum des Berichts:
27. Sep 2004
Betroffene Pakete:
getmail
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In der Debian-Fehlerdatenbank: Fehler 272561.
In Mitres CVE-Verzeichnis: CVE-2004-0880, CVE-2004-0881.
Weitere Informationen:

Ein Sicherheitsproblem wurde in getmail entdeckt, einem Abhol- und Weiterleitungsprogramm für POP3- und APOP-E-Mail. Ein Angreifer mit einem Shellkonto auf dem Rechner des Opfers kann getmail verwenden, um beliebige Dateien zu überschreiben, wenn das Programm als Root ausgeführt wird.

Für die Stable-Distribution (Woody) wurde dieses Problem in Version 2.3.7-2 behoben.

Für die Unstable-Distribution (Sid) wurde dieses Problem in Version 3.2.5-1 behoben.

Wir empfehlen Ihnen, Ihr getmail-Paket zu aktualisieren.

Behoben in:

Debian GNU/Linux 3.0 (woody)

Quellcode:
http://security.debian.org/pool/updates/main/g/getmail/getmail_2.3.7-2.dsc
http://security.debian.org/pool/updates/main/g/getmail/getmail_2.3.7-2.diff.gz
http://security.debian.org/pool/updates/main/g/getmail/getmail_2.3.7.orig.tar.gz
Architektur-unabhängige Dateien:
http://security.debian.org/pool/updates/main/g/getmail/getmail_2.3.7-2_all.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.