Debian-Sicherheitsankündigung

DSA-565-1 sox -- Pufferüberlauf

Datum des Berichts:
13. Okt 2004
Betroffene Pakete:
sox
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In der Debian-Fehlerdatenbank: Fehler 262083.
In Mitres CVE-Verzeichnis: CVE-2004-0557.
Weitere Informationen:

Ulf Härnhammar hat zwei Verwundbarkeiten in SoX gemeldet, einem universellen Konvertierungsprogramm für Sounddateien. Böswillige Personen können diese ausnutzen, um das System eines Benutzers mit einer speziell präparierten .wav-Datei zu kompromittieren.

Für die Stable-Distribution (Woody) wurden diese Probleme in Version 12.17.3-4woody2 behoben.

Für die Unstable-Distribution (Sid) wurden diese Probleme in Version 12.17.4-9 behoben.

Wir empfehlen Ihnen, Ihr mpg123-Paket zu aktualisieren.

Behoben in:

Debian GNU/Linux 3.0 (woody)

Quellcode:
http://security.debian.org/pool/updates/main/s/sox/sox_12.17.3-4woody2.dsc
http://security.debian.org/pool/updates/main/s/sox/sox_12.17.3-4woody2.diff.gz
http://security.debian.org/pool/updates/main/s/sox/sox_12.17.3.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/s/sox/sox_12.17.3-4woody2_alpha.deb
http://security.debian.org/pool/updates/main/s/sox/sox-dev_12.17.3-4woody2_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/s/sox/sox_12.17.3-4woody2_arm.deb
http://security.debian.org/pool/updates/main/s/sox/sox-dev_12.17.3-4woody2_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/s/sox/sox_12.17.3-4woody2_i386.deb
http://security.debian.org/pool/updates/main/s/sox/sox-dev_12.17.3-4woody2_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/s/sox/sox_12.17.3-4woody2_ia64.deb
http://security.debian.org/pool/updates/main/s/sox/sox-dev_12.17.3-4woody2_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/s/sox/sox_12.17.3-4woody2_hppa.deb
http://security.debian.org/pool/updates/main/s/sox/sox-dev_12.17.3-4woody2_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/s/sox/sox_12.17.3-4woody2_m68k.deb
http://security.debian.org/pool/updates/main/s/sox/sox-dev_12.17.3-4woody2_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/s/sox/sox_12.17.3-4woody2_mips.deb
http://security.debian.org/pool/updates/main/s/sox/sox-dev_12.17.3-4woody2_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/s/sox/sox_12.17.3-4woody2_mipsel.deb
http://security.debian.org/pool/updates/main/s/sox/sox-dev_12.17.3-4woody2_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/s/sox/sox_12.17.3-4woody2_powerpc.deb
http://security.debian.org/pool/updates/main/s/sox/sox-dev_12.17.3-4woody2_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/s/sox/sox_12.17.3-4woody2_s390.deb
http://security.debian.org/pool/updates/main/s/sox/sox-dev_12.17.3-4woody2_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/s/sox/sox_12.17.3-4woody2_sparc.deb
http://security.debian.org/pool/updates/main/s/sox/sox-dev_12.17.3-4woody2_sparc.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.