Debian Security Advisory

DSA-580-1 iptables -- missing initialisation

Date Reported:
01 Nov 2004
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 219686.
In Mitre's CVE dictionary: CVE-2004-0986.
More information:

Faheem Mitha noticed that the iptables command, an administration tool for IPv4 packet filtering and NAT, did not always load the required modules on its own as it was supposed to. This could lead to firewall rules not being loaded on system startup. This caused a failure in connection with rules provided by lokkit at least.

For the stable distribution (woody) this problem has been fixed in version 1.2.6a-5.0woody2.

For the unstable distribution (sid) this problem has been fixed in version 1.2.11-4.

We recommend that you upgrade your iptables package.

Fixed in:

Debian GNU/Linux 3.0 (woody)

Intel IA-32:
Intel IA-64:
Motorola 680x0:
Big endian MIPS:
Little endian MIPS:
IBM S/390:
Sun Sparc:

MD5 checksums of the listed files are available in the original advisory.