Alerta de Segurança Debian

DSA-606-1 nfs-utils -- gerenciador de sinal errado

Data do Alerta:
08 Dez 2004
Pacotes Afetados:
nfs-utils
Vulnerável:
Sim
Referência à base de dados de segurança:
No dicionário CVE do Mitre: CVE-2004-1014.
Informações adicionais:

SGI descobriu que o rpc.statd do pacote nfs-util, o Monitor do Estado da Rede, não ignorava o "SIGPIPE". Assim, um cliente poderia terminar o processo do servidor terminando prematuramente a conexão TCP.

Na a distribuição estável (woody), este problema foi corrigido na versão 1.0-2woody2.

Na a distribuição instável (sid), este problema será corrigido em breve.

Nós recomendamos que você atualize seu pacote nfs-util.

Corrigido em:

Debian GNU/Linux 3.0 (woody)

Fonte:
http://security.debian.org/pool/updates/main/n/nfs-utils/nfs-utils_1.0-2woody3.dsc
http://security.debian.org/pool/updates/main/n/nfs-utils/nfs-utils_1.0-2woody3.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/n/nfs-utils/nfs-common_1.0-2woody3_alpha.deb
http://security.debian.org/pool/updates/main/n/nfs-utils/nfs-kernel-server_1.0-2woody3_alpha.deb
http://security.debian.org/pool/updates/main/n/nfs-utils/nhfsstone_1.0-2woody3_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/n/nfs-utils/nfs-common_1.0-2woody3_arm.deb
http://security.debian.org/pool/updates/main/n/nfs-utils/nfs-kernel-server_1.0-2woody3_arm.deb
http://security.debian.org/pool/updates/main/n/nfs-utils/nhfsstone_1.0-2woody3_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/n/nfs-utils/nfs-common_1.0-2woody3_i386.deb
http://security.debian.org/pool/updates/main/n/nfs-utils/nfs-kernel-server_1.0-2woody3_i386.deb
http://security.debian.org/pool/updates/main/n/nfs-utils/nhfsstone_1.0-2woody3_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/n/nfs-utils/nfs-common_1.0-2woody3_ia64.deb
http://security.debian.org/pool/updates/main/n/nfs-utils/nfs-kernel-server_1.0-2woody3_ia64.deb
http://security.debian.org/pool/updates/main/n/nfs-utils/nhfsstone_1.0-2woody3_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/n/nfs-utils/nfs-common_1.0-2woody3_hppa.deb
http://security.debian.org/pool/updates/main/n/nfs-utils/nfs-kernel-server_1.0-2woody3_hppa.deb
http://security.debian.org/pool/updates/main/n/nfs-utils/nhfsstone_1.0-2woody3_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/n/nfs-utils/nfs-common_1.0-2woody3_m68k.deb
http://security.debian.org/pool/updates/main/n/nfs-utils/nfs-kernel-server_1.0-2woody3_m68k.deb
http://security.debian.org/pool/updates/main/n/nfs-utils/nhfsstone_1.0-2woody3_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/n/nfs-utils/nfs-common_1.0-2woody3_mips.deb
http://security.debian.org/pool/updates/main/n/nfs-utils/nfs-kernel-server_1.0-2woody3_mips.deb
http://security.debian.org/pool/updates/main/n/nfs-utils/nhfsstone_1.0-2woody3_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/n/nfs-utils/nfs-common_1.0-2woody3_mipsel.deb
http://security.debian.org/pool/updates/main/n/nfs-utils/nfs-kernel-server_1.0-2woody3_mipsel.deb
http://security.debian.org/pool/updates/main/n/nfs-utils/nhfsstone_1.0-2woody3_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/n/nfs-utils/nfs-common_1.0-2woody3_powerpc.deb
http://security.debian.org/pool/updates/main/n/nfs-utils/nfs-kernel-server_1.0-2woody3_powerpc.deb
http://security.debian.org/pool/updates/main/n/nfs-utils/nhfsstone_1.0-2woody3_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/n/nfs-utils/nfs-common_1.0-2woody3_s390.deb
http://security.debian.org/pool/updates/main/n/nfs-utils/nfs-kernel-server_1.0-2woody3_s390.deb
http://security.debian.org/pool/updates/main/n/nfs-utils/nhfsstone_1.0-2woody3_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/n/nfs-utils/nfs-common_1.0-2woody3_sparc.deb
http://security.debian.org/pool/updates/main/n/nfs-utils/nfs-kernel-server_1.0-2woody3_sparc.deb
http://security.debian.org/pool/updates/main/n/nfs-utils/nhfsstone_1.0-2woody3_sparc.deb

Checksums MD5 dos arquivos listados estão disponíveis no alerta original.