Bulletin d'alerte Debian

DSA-619-1 xpdf -- Dépassement de tampon

Date du rapport :
30 décembre 2004
Paquets concernés :
xpdf
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 286742, Bogue 286983.
Dans le dictionnaire CVE du Mitre : CVE-2004-1125.
Plus de précisions :

Un expert en sécurité de iDEFENSE a découvert un dépassement de tampon dans xpdf, un visualisateur pour fichiers PDF. Un fichier PDF spécialement conçu pouvait exploiter ce problème pour exécuter un code arbitraire.

Pour l'actuelle distribution stable (Woody), ce problème a été corrigé dans la version 1.00-3.3.

Pour la distribution instable (Sid), ce problème a été corrigé dans la version 3.00-11.

Nous vous recommandons de mettre à jour votre paquet xpdf immédiatement.

Corrigé dans :

Debian GNU/Linux 3.0 (woody)

Source :
http://security.debian.org/pool/updates/main/x/xpdf/xpdf_1.00-3.3.dsc
http://security.debian.org/pool/updates/main/x/xpdf/xpdf_1.00-3.3.diff.gz
http://security.debian.org/pool/updates/main/x/xpdf/xpdf_1.00.orig.tar.gz
Composant indépendant de l'architecture :
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-common_1.00-3.3_all.deb
http://security.debian.org/pool/updates/main/x/xpdf/xpdf_1.00-3.3_all.deb
Alpha:
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-reader_1.00-3.3_alpha.deb
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-utils_1.00-3.3_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-reader_1.00-3.3_arm.deb
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-utils_1.00-3.3_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-reader_1.00-3.3_i386.deb
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-utils_1.00-3.3_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-reader_1.00-3.3_ia64.deb
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-utils_1.00-3.3_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-reader_1.00-3.3_hppa.deb
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-utils_1.00-3.3_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-reader_1.00-3.3_m68k.deb
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-utils_1.00-3.3_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-reader_1.00-3.3_mips.deb
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-utils_1.00-3.3_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-reader_1.00-3.3_mipsel.deb
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-utils_1.00-3.3_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-reader_1.00-3.3_powerpc.deb
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-utils_1.00-3.3_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-reader_1.00-3.3_s390.deb
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-utils_1.00-3.3_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-reader_1.00-3.3_sparc.deb
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-utils_1.00-3.3_sparc.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.