Debian セキュリティ勧告

DSA-633-1 bmv -- 安全でない一時ファイルの作成

報告日時:
2005-01-11
影響を受けるパッケージ:
bmv
危険性:
あり
参考セキュリティデータベース:
Mitre の CVE 辞書: CVE-2003-0014.
詳細:

SVGAlib 用の PostScirpt ビューア bmv の開発元のメンテナである Peter Samuelson さんは、このソフトの一時ファイルが安全ではない方法で作成されているのを発見しました。 悪意をもったローカルユーザーが、シンボリックリンク攻撃によって任意のファイルを上書きできてしまいます。

安定版ディストリビューション (stable、コードネーム woody) では、この問題はバージョン 1.2-14.2 で修正されています。

不安定版ディストリビューション (unstable、コードネーム sid) では、この問題はバージョン 1.2-17 で修正されています。

bmv パッケージのアップグレードをお勧めします。

修正:

Debian GNU/Linux 3.0 (woody)

ソース:
http://security.debian.org/pool/updates/main/b/bmv/bmv_1.2-14.2.dsc
http://security.debian.org/pool/updates/main/b/bmv/bmv_1.2-14.2.diff.gz
http://security.debian.org/pool/updates/main/b/bmv/bmv_1.2.orig.tar.gz
Intel IA-32:
http://security.debian.org/pool/updates/main/b/bmv/bmv_1.2-14.2_i386.deb

一覧にあるファイルの MD5 チェックサムは勧告の原文にあります。