Рекомендация Debian по безопасности

DSA-642-1 gallery -- несколько уязвимостей

Дата сообщения:
17.01.2005
Затронутые пакеты:
gallery
Уязвим:
Да
Ссылки на базы данных по безопасности:
В базе данных Bugtraq (на SecurityFocus): Идентификатор BugTraq 11602.
В каталоге Mitre CVE: CVE-2004-1106.
Более подробная информация:

В gallery, фотоальбоме для веб, написанном на PHP4, было обнаружено несколько уязвимостей. Проект Common Vulnerabilities and Exposures определяет следующие уязвимости:

  • CAN-2004-1106

    Джим Пэрис обнаружил межсайтовый скриптинг, который позволяет вставлять код, используя специально сформированные URL.

  • CVE-NOMATCH

    Разработчики основной ветки разработки исправили несколько случаев возможных инъекций переменной, которые могут приводить к тому, что gallery выполнит какие-нибудь посторонние действия, например, раскроет базу данных паролей.

В стабильном выпуске (woody) эти проблемы были исправлены в версии 1.2.5-8woody3.

В нестабильном выпуске (sid) эти проблемы были исправлены в версии 1.4.4-pl4-1.

Рекомендуется обновить пакет gallery.

Исправлено в:

Debian GNU/Linux 3.0 (woody)

Исходный код:
http://security.debian.org/pool/updates/main/g/gallery/gallery_1.2.5-8woody3.dsc
http://security.debian.org/pool/updates/main/g/gallery/gallery_1.2.5-8woody3.diff.gz
http://security.debian.org/pool/updates/main/g/gallery/gallery_1.2.5.orig.tar.gz
Независимые от архитектуры компоненты:
http://security.debian.org/pool/updates/main/g/gallery/gallery_1.2.5-8woody3_all.deb

Контрольные суммы MD5 этих файлов доступны в исходном сообщении.