Bulletin d'alerte Debian

DSA-659-1 libpam-radius-auth -- Fuite d'informations, dépassement d'entier par le bas

Date du rapport :
26 janvier 2005
Paquets concernés :
libpam-radius-auth
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2004-1340, CVE-2005-0108.
Plus de précisions :

Deux problèmes ont été découverts dans le paquet libpam-radius-auth, le module d'authentification RADIUS pour PAM. Le projet « Common Vulnerabilities and Exposures » a identifié les problèmes suivants :

  • CAN-2004-1340

    Le paquet Debian installait accidentellement son fichier de configuration /etc/pam_radius_auth.conf lisible par tous. Si celui-ci contenait des informations sensibles, tous les utilisateurs locaux étaient capables de les lire, sauf si l'administrateur avait ajusté les permissions des fichiers. Ce problème était spécifique à Debian.

  • CAN-2005-0108

    Leon Juranic a découvert un dépassement d'entier par le bas dans le module mod_auth_radius pour Apache, également présent dans libpam-radius-auth.

Pour l'actuelle distribution stable (Woody), ces problèmes ont été corrigés dans la version 1.3.14-1.3.

Pour la distribution instable (Sid), ces problèmes ont été corrigés dans la version 1.3.16-3.

Nous vous recommandons de mettre à jour votre paquet libpam-radius-auth.

Corrigé dans :

Debian GNU/Linux 3.0 (woody)

Source :
http://security.debian.org/pool/updates/main/libp/libpam-radius-auth/libpam-radius-auth_1.3.14-1.3.dsc
http://security.debian.org/pool/updates/main/libp/libpam-radius-auth/libpam-radius-auth_1.3.14-1.3.diff.gz
http://security.debian.org/pool/updates/main/libp/libpam-radius-auth/libpam-radius-auth_1.3.14.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/libp/libpam-radius-auth/libpam-radius-auth_1.3.14-1.3_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/libp/libpam-radius-auth/libpam-radius-auth_1.3.14-1.3_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/libp/libpam-radius-auth/libpam-radius-auth_1.3.14-1.3_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/libp/libpam-radius-auth/libpam-radius-auth_1.3.14-1.3_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/libp/libpam-radius-auth/libpam-radius-auth_1.3.14-1.3_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/libp/libpam-radius-auth/libpam-radius-auth_1.3.14-1.3_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/libp/libpam-radius-auth/libpam-radius-auth_1.3.14-1.3_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/libp/libpam-radius-auth/libpam-radius-auth_1.3.14-1.3_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/libp/libpam-radius-auth/libpam-radius-auth_1.3.14-1.3_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/libp/libpam-radius-auth/libpam-radius-auth_1.3.14-1.3_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/libp/libpam-radius-auth/libpam-radius-auth_1.3.14-1.3_sparc.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.