Debians sikkerhedsbulletin

DSA-897-1 phpsysinfo -- programmeringsfejl

Rapporteret den:
15. nov 2005
Berørte pakker:
phpsysinfo
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 301118.
I Mitres CVE-ordbog: CVE-2005-0870, CVE-2005-3347, CVE-2005-3348.
Yderligere oplysninger:

Flere sårbarheder er opdaget i phpsysinfo, et PHP-baseret program der viser oplysninger om værtsmaskinen. Projektet Common Vulnerabilities and Exposures har fundet frem til følgende problemer:

  • CVE-2005-0870

    Maksymilian Arciemowicz har opdaget flere problemer med udførelse af skripter på tværs af servere, hvoraf ikke alle blev rettet i DSA 724.

  • CVE-2005-3347

    Christopher Kunz har opdaget at lokale variable blev overskrivet betingelsesløst og at de senere blev anset for at være troværdige, hvilket kunne medføre indlæsning af vilkårlige filer.

  • CVE-2005-3348

    Christopher Kunz har opdaget at brugerleverede inddata anvendes ukontrolleret, hvilket forårsagede et opsplitningsproblem i HTTP Response.

I den gamle stabile distribution (woody) er disse problemer rettet i version 2.0-3woody3.

I den stabile distribution (sarge) er disse problemer rettet i version 2.3-4sarge1.

I den ustabile distribution (sid) vil disse problemer snart blive rettet.

Vi anbefaler at du opgraderer din phpsysinfo-pakke.

Rettet i:

Debian GNU/Linux 3.0 (woody)

Kildekode:
http://security.debian.org/pool/updates/main/p/phpsysinfo/phpsysinfo_2.0-3woody3.dsc
http://security.debian.org/pool/updates/main/p/phpsysinfo/phpsysinfo_2.0-3woody3.diff.gz
http://security.debian.org/pool/updates/main/p/phpsysinfo/phpsysinfo_2.0.orig.tar.gz
Arkitekturuafhængig komponent:
http://security.debian.org/pool/updates/main/p/phpsysinfo/phpsysinfo_2.0-3woody3_all.deb

Debian GNU/Linux 3.1 (sarge)

Kildekode:
http://security.debian.org/pool/updates/main/p/phpsysinfo/phpsysinfo_2.3-4sarge1.dsc
http://security.debian.org/pool/updates/main/p/phpsysinfo/phpsysinfo_2.3-4sarge1.diff.gz
http://security.debian.org/pool/updates/main/p/phpsysinfo/phpsysinfo_2.3.orig.tar.gz
Arkitekturuafhængig komponent:
http://security.debian.org/pool/updates/main/p/phpsysinfo/phpsysinfo_2.3-4sarge1_all.deb

MD5-kontrolsummer for de listede filer findes i den originale sikkerhedsbulletin.