Рекомендация Debian по безопасности

DSA-901-1 gnump3d -- ошибка программирования

Дата сообщения:
19.11.2005
Затронутые пакеты:
gnump3d
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2005-3349, CVE-2005-3355.
Более подробная информация:

В gnump3d, сервере потокового вещания файлов MP3 и OGG, было обнаружено несколько уязвимостей. Проект Common Vulnerabilities and Exposures определяет следующие проблемы:

  • CVE-2005-3349

    Людвиг Нуссель обнаружил несколько временных файлов, которые создаются небезопасным образом и имеют предсказуемые имена, что позволяет локальным злоумышленникам выполнять атаки через символьные ссылки.

  • CVE-2005-3355

    Людвиг Нуссель обнаружил, что параметр темы в HTTP-запроса может использоваться для обхода пути.

В предыдущем стабильном выпуске (woody) пакет gnump3d отсутствует.

В стабильном выпуске (sarge) эти проблемы были исправлены в версии 2.9.3-1sarge3.

В нестабильном выпуске (sid) эти проблемы были исправлены в версии 2.9.8-1.

Рекомендуется обновить пакет gnump3.

Исправлено в:

Debian GNU/Linux 3.1 (sarge)

Исходный код:
http://security.debian.org/pool/updates/main/g/gnump3d/gnump3d_2.9.3-1sarge3.dsc
http://security.debian.org/pool/updates/main/g/gnump3d/gnump3d_2.9.3-1sarge3.diff.gz
http://security.debian.org/pool/updates/main/g/gnump3d/gnump3d_2.9.3.orig.tar.gz
Независимые от архитектуры компоненты:
http://security.debian.org/pool/updates/main/g/gnump3d/gnump3d_2.9.3-1sarge3_all.deb

Контрольные суммы MD5 этих файлов доступны в исходном сообщении.