Alerta de Segurança Debian

DSA-1027-1 mailman -- erro de programação

Data do Alerta:
06 Abr 2006
Pacotes Afetados:
mailman
Vulnerável:
Sim
Referência à base de dados de segurança:
No sistema de acompanhamento de bugs do Debian: Bug 358892.
No dicionário CVE do Mitre: CVE-2006-0052.
Informações adicionais:

Um potencial problema de negação de serviço foi descoberto no mailman, o gerenciador de listas de e-mail baseado em web. O (falho) tratamento de mensagens com multi-partes mime mal formadas algumas vezes fez com que toda a lista de e-mail se tornasse inoperante.

A antiga distribuição estável ("woody") não é vulnerável a esta falha.

Para a distribuição estável ("sarge") este problema foi corrigido na versão 2.1.5-8sarge2.

Para a distribuição instável ("sid") este problema será corrigido em breve.

Recomendamos que você atualize seu pacote mailman.

Corrigido em:

Debian GNU/Linux 3.1 (sarge)

Fonte:
http://security.debian.org/pool/updates/main/m/mailman/mailman_2.1.5-8sarge2.dsc
http://security.debian.org/pool/updates/main/m/mailman/mailman_2.1.5-8sarge2.diff.gz
http://security.debian.org/pool/updates/main/m/mailman/mailman_2.1.5.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/m/mailman/mailman_2.1.5-8sarge2_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/m/mailman/mailman_2.1.5-8sarge2_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/m/mailman/mailman_2.1.5-8sarge2_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/m/mailman/mailman_2.1.5-8sarge2_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/m/mailman/mailman_2.1.5-8sarge2_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/m/mailman/mailman_2.1.5-8sarge2_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/m/mailman/mailman_2.1.5-8sarge2_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/m/mailman/mailman_2.1.5-8sarge2_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/m/mailman/mailman_2.1.5-8sarge2_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/m/mailman/mailman_2.1.5-8sarge2_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/m/mailman/mailman_2.1.5-8sarge2_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/m/mailman/mailman_2.1.5-8sarge2_sparc.deb

Checksums MD5 dos arquivos listados estão disponíveis no alerta original.