Debian Security Advisory

DSA-1039-1 blender -- several vulnerabilities

Date Reported:
24 Apr 2006
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 330895, Bug 344398.
In the Bugtraq database (at SecurityFocus): BugTraq ID 15981.
In Mitre's CVE dictionary: CVE-2005-3302, CVE-2005-4470.
More information:

Several vulnerabilities have been discovered in blender, a very fast and versatile 3D modeller/renderer. The Common Vulnerabilities and Exposures Project identifies the following problems:

  • CVE-2005-3302

    Joxean Koret discovered that due to missing input validation a provided script is vulnerable to arbitrary command execution.

  • CVE-2005-4470

    Damian Put discovered a buffer overflow that allows remote attackers to cause a denial of service and possibly execute arbitrary code.

The old stable distribution (woody) is not affected by this problem.

For the stable distribution (sarge) this problem has been fixed in version 2.36-1sarge1.

For the unstable distribution (sid) this problem has been fixed in version 2.40-1.

We recommend that you upgrade your blender package.

Fixed in:

Debian GNU/Linux 3.1 (sarge)

Intel IA-32:
Intel IA-64:
Motorola 680x0:
Big endian MIPS:
Little endian MIPS:
IBM S/390:
Sun Sparc:

MD5 checksums of the listed files are available in the original advisory.