Bulletin d'alerte Debian

DSA-1056-1 webcalendar -- Message d'erreur trop détaillé

Date du rapport :
15 mai 2006
Paquets concernés :
webcalendar
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 366927.
Dans le dictionnaire CVE du Mitre : CVE-2006-2247.
Plus de précisions :

David Maciejak a remarqué que webcalendar, un calendrier multiutilisateurs basé sur PHP, retournait des messages d'erreur différents lors d'une erreur de mot de passe ou d'utilisateur inexistant, ce qui permettait à des attaquants distants d'obtenir des informations sur les identifiants d'utilisateurs valides.

L'ancienne distribution stable (Woody) ne contient pas le paquet webcalendar.

Pour l'actuelle distribution stable (Sarge), ce problème a été corrigé dans la version 0.9.45-4sarge4.

Pour la distribution instable (Sid), ce problème sera bientôt corrigé.

Nous vous recommandons de mettre à jour votre paquet webcalendar.

Corrigé dans :

Debian GNU/Linux 3.1 (sarge)

Source :
http://security.debian.org/pool/updates/main/w/webcalendar/webcalendar_0.9.45-4sarge4.dsc
http://security.debian.org/pool/updates/main/w/webcalendar/webcalendar_0.9.45-4sarge4.diff.gz
http://security.debian.org/pool/updates/main/w/webcalendar/webcalendar_0.9.45.orig.tar.gz
Composant indépendant de l'architecture :
http://security.debian.org/pool/updates/main/w/webcalendar/webcalendar_0.9.45-4sarge4_all.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.