Рекомендация Debian по безопасности

DSA-1056-1 webcalendar -- подробное сообщение об ошибке

Дата сообщения:
15.05.2006
Затронутые пакеты:
webcalendar
Уязвим:
Да
Ссылки на базы данных по безопасности:
В системе отслеживания ошибок Debian: Ошибка 366927.
В каталоге Mitre CVE: CVE-2006-2247.
Более подробная информация:

Давид Макияк обнаружил, что webcalendar, многопользовательский календарь на основе PHP, возвращает разные сообщения об ошибках при осуществлении попытки входа в случаях ввода неправильного пароля и отсутствия пользователя, что позволяет удалённым злоумышленникам получить информацию о корректных именах пользователей.

В предыдущем стабильном выпуске (woody) пакет webcalendar отсутствует.

В стабильном выпуске (sarge) эта проблема была исправлена в версии 0.9.45-4sarge4.

В нестабильном выпуске (sid) эта проблема будет исправлена позже.

Рекомендуется обновить пакет webcalendar.

Исправлено в:

Debian GNU/Linux 3.1 (sarge)

Исходный код:
http://security.debian.org/pool/updates/main/w/webcalendar/webcalendar_0.9.45-4sarge4.dsc
http://security.debian.org/pool/updates/main/w/webcalendar/webcalendar_0.9.45-4sarge4.diff.gz
http://security.debian.org/pool/updates/main/w/webcalendar/webcalendar_0.9.45.orig.tar.gz
Независимые от архитектуры компоненты:
http://security.debian.org/pool/updates/main/w/webcalendar/webcalendar_0.9.45-4sarge4_all.deb

Контрольные суммы MD5 этих файлов доступны в исходном сообщении.