Säkerhetsbulletin från Debian

DSA-1056-1 webcalendar -- ordrikt felmeddelande

Rapporterat den:
2006-05-15
Berörda paket:
webcalendar
Sårbara:
Ja
Referenser i säkerhetsdatabaser:
I Debians felrapporteringssystem: Fel 366927.
I Mitres CVE-förteckning: CVE-2006-2247.
Ytterligare information:

David Maciejak upptäckte att webcalendar, en PHP-baserad fleranvändarkalender, gav olika felmeddelanden vid inloggningsförsök för ett ogiltigt lösenord och en icke-existerande användare, vilket gjorde det möjligt för angripare utifrån att få tag i information om giltiga användar-id.

Den gamla stabila utgåvan (Woody) innehåller inte paketet webcalendar.

För den stabila utgåvan (Sarge) har detta problem rättats i version 0.9.45-4sarge4.

För den instabila utgåvan (Sid) kommer detta problem rättas inom kort.

Vi rekommenderar att ni uppgraderar ert webcalendar-paket.

Rättat i:

Debian GNU/Linux 3.1 (sarge)

Källkod:
http://security.debian.org/pool/updates/main/w/webcalendar/webcalendar_0.9.45-4sarge4.dsc
http://security.debian.org/pool/updates/main/w/webcalendar/webcalendar_0.9.45-4sarge4.diff.gz
http://security.debian.org/pool/updates/main/w/webcalendar/webcalendar_0.9.45.orig.tar.gz
Arkitekturoberoende komponent:
http://security.debian.org/pool/updates/main/w/webcalendar/webcalendar_0.9.45-4sarge4_all.deb

MD5-kontrollsummor för dessa filer finns i originalbulletinen.