Рекомендация Debian по безопасности

DSA-1061-1 popfile -- отсутствие очистки ввода

Дата сообщения:
19.05.2006
Затронутые пакеты:
popfile
Уязвим:
Да
Ссылки на базы данных по безопасности:
В системе отслеживания ошибок Debian: Ошибка 354464.
В каталоге Mitre CVE: CVE-2006-0876.
Более подробная информация:

Было обнаружено, что работа popfile, байесовского классификатора почты, может быть завершена аварийно из-за некорректного набора символов в сообщении электронной почты, что приводит к отказу в обслуживании.

В предыдущем стабильном выпуске (woody) пакеты popfile отсутствуют.

В стабильном выпуске (sarge) эта проблема была исправлена в версии 0.22.2-2sarge1.

В нестабильном выпуске (sid) эта проблема была исправлена в версии 0.22.4-1.

Рекомендуется обновить пакет popfile.

Исправлено в:

Debian GNU/Linux 3.1 (sarge)

Исходный код:
http://security.debian.org/pool/updates/main/p/popfile/popfile_0.22.2-2sarge1.dsc
http://security.debian.org/pool/updates/main/p/popfile/popfile_0.22.2-2sarge1.diff.gz
http://security.debian.org/pool/updates/main/p/popfile/popfile_0.22.2.orig.tar.gz
Независимые от архитектуры компоненты:
http://security.debian.org/pool/updates/main/p/popfile/popfile_0.22.2-2sarge1_all.deb

Контрольные суммы MD5 этих файлов доступны в исходном сообщении.