Bulletin d'alerte Debian

DSA-1186-1 cscope -- Dépassements de mémoire tampon

Date du rapport :
30 septembre 2006
Paquets concernés :
cscope
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 385893.
Dans le dictionnaire CVE du Mitre : CVE-2006-4262.
Plus de précisions :

Will Drewry de l'équipe de sécurité de Google a découvert plusieurs dépassements de mémoire tampon dans cscope, un outil de navigation dans le code source, cela peut conduire à l'exécution de code arbitraire.

Pour la distribution stable (Sarge), ce problème a été corrigé dans la version 15.5-1.1sarge2.

Pour la distribution instable (Sid), ce problème a été corrigé dans la version 15.5+cvs20060902-1.

Nous vous recommandons de mettre à jour votre paquet cscope.

Corrigé dans :

Debian GNU/Linux 3.1 (sarge)

Source :
http://security.debian.org/pool/updates/main/c/cscope/cscope_15.5-1.1sarge2.dsc
http://security.debian.org/pool/updates/main/c/cscope/cscope_15.5-1.1sarge2.diff.gz
http://security.debian.org/pool/updates/main/c/cscope/cscope_15.5.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/c/cscope/cscope_15.5-1.1sarge2_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/c/cscope/cscope_15.5-1.1sarge2_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/c/cscope/cscope_15.5-1.1sarge2_arm.deb
HPPA:
http://security.debian.org/pool/updates/main/c/cscope/cscope_15.5-1.1sarge2_hppa.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/c/cscope/cscope_15.5-1.1sarge2_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/c/cscope/cscope_15.5-1.1sarge2_ia64.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/c/cscope/cscope_15.5-1.1sarge2_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/c/cscope/cscope_15.5-1.1sarge2_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/c/cscope/cscope_15.5-1.1sarge2_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/c/cscope/cscope_15.5-1.1sarge2_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/c/cscope/cscope_15.5-1.1sarge2_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/c/cscope/cscope_15.5-1.1sarge2_sparc.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.