Bulletin d'alerte Debian

DSA-969-1 scponly -- Erreur de conception

Date du rapport :
13 février 2006
Paquets concernés :
scponly
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 344418.
Dans le dictionnaire CVE du Mitre : CVE-2005-4532, CVE-2005-4533.
Plus de précisions :

Max Vozeler a découvert une vulnérabilité dans scponly, un outil pour restreindre les commandes de l'utilisateur à scp et sftp, qui pouvait permettre l'exécution de commandes arbitraires en tant que superutilisateur. Le système n'était vulnérable que si le programme scponlyc était installé en mode setuid root et que des utilisateurs avaient accès à une invite de commande sur la machine.

L'ancienne distribution stable (Woody) ne contient pas de paquet scponly.

Pour l'actuelle distribution stable (Sarge), ce problème a été corrigé dans la version 4.0-1sarge1.

Pour la distribution instable (Sid), ce problème a été corrigé dans la version 4.6-1.

Nous vous recommandons de mettre à jour votre paquet scponly.

Corrigé dans :

Debian GNU/Linux 3.1 (sarge)

Source :
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.0-1sarge1.dsc
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.0-1sarge1.diff.gz
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.0.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.0-1sarge1_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.0-1sarge1_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.0-1sarge1_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.0-1sarge1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.0-1sarge1_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.0-1sarge1_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.0-1sarge1_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.0-1sarge1_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.0-1sarge1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.0-1sarge1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.0-1sarge1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/s/scponly/scponly_4.0-1sarge1_sparc.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.