Debian セキュリティ勧告

DSA-970-1 kronolith -- 入力のサニタイジング欠落

報告日時:
2006-02-14
影響を受けるパッケージ:
kronolith
危険性:
あり
参考セキュリティデータベース:
Debian バグ追跡システム: バグ 342943, バグ 349261.
Mitre の CVE 辞書: CVE-2005-4189.
詳細:

SEC Consult の Johannes Greil さんが、クロスサイトスクリプティング脆弱性を複数、 Horde カレンダーアプリケーション kronolith に発見しました。

旧安定版 (old stable) ディストリビューション (woody) には kronolith パッケージは含まれません。

安定版 (stable) ディストリビューション (sarge) では、この問題はバージョン 1.1.4-2sarge1 で修正されています。

不安定版 (unstable) ディストリビューション (sid) では、この問題は kronolith2 のバージョン 2.0.6-1 で修正されています。

直ちに kronolith および kronolith2 パッケージをアップグレードすることを勧めます。

修正:

Debian GNU/Linux 3.1 (sarge)

ソース:
http://security.debian.org/pool/updates/main/k/kronolith/kronolith_1.1.4-2sarge1.dsc
http://security.debian.org/pool/updates/main/k/kronolith/kronolith_1.1.4-2sarge1.diff.gz
http://security.debian.org/pool/updates/main/k/kronolith/kronolith_1.1.4.orig.tar.gz
アーキテクチャ非依存コンポーネント:
http://security.debian.org/pool/updates/main/k/kronolith/kronolith_1.1.4-2sarge1_all.deb

一覧にあるファイルの MD5 チェックサムは勧告の原文にあります。