Debian-Sicherheitsankündigung

DSA-989-1 zoph -- SQL-Injektion

Datum des Berichts:
09. Mär 2006
Betroffene Pakete:
zoph
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In der Debian-Fehlerdatenbank: Fehler 350717.
In Mitres CVE-Verzeichnis: CVE-2006-0402.
Weitere Informationen:

Neil McBride entdeckte, dass Zoph, ein Web-basiertes Fotoverwaltungssystem, eingegebene Daten zur Fotosuche nur unzureichend überprüft, was über einen SQL-Injektions-Angriff zu der Ausführung von SQL-Befehlen führen kann.

Die alte Stable-Distribution (Woody) enthält das zoph-Paket nicht.

Für die Stable-Distribution (Sarge) wurde dieses Problem in Version 0.3.3-12sarge1 behoben.

Für die Unstable-Distribution (Sid) wurde dieses Problem in Version 0.5-1 behoben.

Wir empfehlen Ihnen, Ihr zoph-Paket zu aktualisieren.

Behoben in:

Debian GNU/Linux 3.1 (sarge)

Quellcode:
http://security.debian.org/pool/updates/main/z/zoph/zoph_0.3.3-12sarge1.dsc
http://security.debian.org/pool/updates/main/z/zoph/zoph_0.3.3-12sarge1.diff.gz
http://security.debian.org/pool/updates/main/z/zoph/zoph_0.3.3.orig.tar.gz
Architektur-unabhängige Dateien:
http://security.debian.org/pool/updates/main/z/zoph/zoph_0.3.3-12sarge1_all.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.