Aviso de seguridad de Debian

DSA-989-1 zoph -- Inyección SQL

Fecha del informe:
9 de mar de 2006
Paquetes afectados:
zoph
Vulnerable:
Referencias a bases de datos de seguridad:
En el sistema de seguimiento de errores de Debian: error 350717.
En el diccionario CVE de Mitre: CVE-2006-0402.
Información adicional:

Neil McBride descubrió que Zoph, un sistema web de gestión de fotos, realizaba un saneamiento insufuciente de la entrada que se le pasaba a las búsquedas de fotos, lo que podía conducir a la ejecución de órdenes SQL mediante un ataque de inyección de SQL.

La distribución estable anterior (woody) no contiene el paquete zoph.

Para la distribución estable anterior (sarge), este problema se ha corregido en la versión 0.3.3-12sarge1.

Para la distribución inestable (sid), este problema se ha corregido en la versión 0.5-1.

Le recomendamos que actualice el paquete zoph.

Arreglado en:

Debian GNU/Linux 3.1 (sarge)

Fuentes:
http://security.debian.org/pool/updates/main/z/zoph/zoph_0.3.3-12sarge1.dsc
http://security.debian.org/pool/updates/main/z/zoph/zoph_0.3.3-12sarge1.diff.gz
http://security.debian.org/pool/updates/main/z/zoph/zoph_0.3.3.orig.tar.gz
Componentes independientes de la arquitectura:
http://security.debian.org/pool/updates/main/z/zoph/zoph_0.3.3-12sarge1_all.deb

Las sumas MD5 de los ficheros que se listan están disponibles en el aviso original.