Bulletin d'alerte Debian

DSA-989-1 zoph -- Injection SQL

Date du rapport :
9 mars 2006
Paquets concernés :
zoph
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 350717.
Dans le dictionnaire CVE du Mitre : CVE-2006-0402.
Plus de précisions :

Neil McBride a découvert que Zoph, un système de gestion de photos par le web, ne vérifiait pas correctement les entrées passées pour la recherche de photo, ce qui pouvait permettre l'exécution de commandes SQL en utilisant une attaque d'injection SQL.

L'ancienne distribution stable (Woody) ne contient pas zoph.

Pour l'actuelle distribution stable (Sarge), ce problème a été corrigé dans la version 0.3.3-12sarge1.

Pour la distribution instable (Sid), ce problème a été corrigé dans la version 0.5-1.

Nous vous recommandons de mettre à jour votre paquet zoph.

Corrigé dans :

Debian GNU/Linux 3.1 (sarge)

Source :
http://security.debian.org/pool/updates/main/z/zoph/zoph_0.3.3-12sarge1.dsc
http://security.debian.org/pool/updates/main/z/zoph/zoph_0.3.3-12sarge1.diff.gz
http://security.debian.org/pool/updates/main/z/zoph/zoph_0.3.3.orig.tar.gz
Composant indépendant de l'architecture :
http://security.debian.org/pool/updates/main/z/zoph/zoph_0.3.3-12sarge1_all.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.