Debians sikkerhedsbulletin

DSA-1266-1 gnupg -- flere sårbarheder

Rapporteret den:
13. mar 2007
Berørte pakker:
gnupg
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 413922, Fejl 414170.
I Mitres CVE-ordbog: CVE-2007-1263.
Yderligere oplysninger:

Gerardo Richarte har opdaget at GnuPG, en fri erstatning for PGP, gav utilstrækkelige oplysninger til brugeren hvis en OpenPGP-meddelelse indeholdt både en signeret og en usigneret del. Indsættelse af tekstsegmenter i en ellers signeret medddelelse kunne udnyttes til at forfalske indholdet af signerede meddelelser. Denne opdatering forhindrer sådanne angreb; den gamle virkemåde kan stadig aktiveres vha. valgmuligheden --allow-multiple-messages.

I den stabile distribution (sarge) er disse problemer rettet i version 1.4.1-1.sarge7.

I den kommeunde stabile distribution (etch) er disse problemer rettet i version 1.4.6-2.

I den ustabile distribution (sid) er disse problemer rettet i version 1.4.6-2.

Vi anbefaler at du opgraderer dine gnupg-pakker.

Rettet i:

Debian GNU/Linux 3.1 (sarge)

Kildekode:
http://security.debian.org/pool/updates/main/g/gnupg/gnupg_1.4.1-1.sarge7.dsc
http://security.debian.org/pool/updates/main/g/gnupg/gnupg_1.4.1-1.sarge7.diff.gz
http://security.debian.org/pool/updates/main/g/gnupg/gnupg_1.4.1.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/g/gnupg/gnupg_1.4.1-1.sarge7_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/g/gnupg/gnupg_1.4.1-1.sarge7_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/g/gnupg/gnupg_1.4.1-1.sarge7_arm.deb
HPPA:
http://security.debian.org/pool/updates/main/g/gnupg/gnupg_1.4.1-1.sarge7_hppa.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/g/gnupg/gnupg_1.4.1-1.sarge7_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/g/gnupg/gnupg_1.4.1-1.sarge7_ia64.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/g/gnupg/gnupg_1.4.1-1.sarge7_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/g/gnupg/gnupg_1.4.1-1.sarge7_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/g/gnupg/gnupg_1.4.1-1.sarge7_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/g/gnupg/gnupg_1.4.1-1.sarge7_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/g/gnupg/gnupg_1.4.1-1.sarge7_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/g/gnupg/gnupg_1.4.1-1.sarge7_sparc.deb

MD5-kontrolsummer for de listede filer findes i den originale sikkerhedsbulletin.