Bulletin d'alerte Debian

DSA-1269-1 lookup-el -- Fichier temporaire peu sûr

Date du rapport :
18 mars 2007
Paquets concernés :
lookup-el
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2007-0237.
Plus de précisions :

Tatsuya Kinoshita a découvert que Lookup, une interface de recherche pour les dictionnaires électroniques sur emacsen, créait un fichier temporaire d'une manière peu sûre lorsque la fonction ndeb-binary était utilisée, cela permet à un attaquant local de mener une attaque par lien symbolique pour écraser des fichiers arbitraires.

Pour la distribution stable (Sarge), ce problème a été corrigé dans la version 1.4-3sarge1.

Pour la distribution de test (Etch), ce problème a été corrigé dans la version 1.4-5.

Pour la distribution instable (Sid), ce problème a été corrigé dans la version 1.4-5.

Nous vous recommandons de mettre à jour votre paquet lookup-el.

Corrigé dans :

Debian GNU/Linux 3.1 (sarge)

Source :
http://security.debian.org/pool/updates/main/l/lookup-el/lookup-el_1.4-3sarge1.dsc
http://security.debian.org/pool/updates/main/l/lookup-el/lookup-el_1.4-3sarge1.diff.gz
http://security.debian.org/pool/updates/main/l/lookup-el/lookup-el_1.4.orig.tar.gz
Composant indépendant de l'architecture :
http://security.debian.org/pool/updates/main/l/lookup-el/lookup-el_1.4-3sarge1_all.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.