Рекомендация Debian по безопасности

DSA-1269-1 lookup-el -- небезопасный временный файл

Дата сообщения:
18.03.2007
Затронутые пакеты:
lookup-el
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2007-0237.
Более подробная информация:

Татсюа Киношита обнаружил, что Lookup, поисковый интерфейс для электронных словарей на основе emacsen, при использовании ndeb-binary создаёт временный файл небезопасным образом, что позволяет локальному злоумышленнику выполнить атаку через символьные ссылки для перезаписи произвольных файлов.

В стабильном выпуске (sarge) эта проблема была исправлена в версии 1.4-3sarge1.

В тестируемом выпуске (etch) эта проблема была исправлена в версии 1.4-5.

В нестабильном выпуске (sid) эта проблема была исправлена в версии 1.4-5.

Рекомендуется обновить пакет lookup-el.

Исправлено в:

Debian GNU/Linux 3.1 (sarge)

Исходный код:
http://security.debian.org/pool/updates/main/l/lookup-el/lookup-el_1.4-3sarge1.dsc
http://security.debian.org/pool/updates/main/l/lookup-el/lookup-el_1.4-3sarge1.diff.gz
http://security.debian.org/pool/updates/main/l/lookup-el/lookup-el_1.4.orig.tar.gz
Независимые от архитектуры компоненты:
http://security.debian.org/pool/updates/main/l/lookup-el/lookup-el_1.4-3sarge1_all.deb

Контрольные суммы MD5 этих файлов доступны в исходном сообщении.