Debians sikkerhedsbulletin

DSA-1282-1 php4 -- flere sårbarheder

Rapporteret den:
26. apr 2007
Berørte pakker:
php4
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Mitres CVE-ordbog: CVE-2007-1286, CVE-2007-1380, CVE-2007-1521, CVE-2007-1711, CVE-2007-1718, CVE-2007-1777.
Yderligere oplysninger:

Flere fjernudnytbare særbarheder er opdaget i PHP, et server-side skriptsprog med indlejring af HTML, hvilket kunne føre til udførelse af vilkårlig kode. Projektet Common Vulnerabilities and Exposures har fundet frem til følgende problemer:

  • CVE-2007-1286

    Stefan Esser opdagede et overløb i objektreferencehåndteringskoden i funktionen unserialize(), hvilket gjorde det muligt at udføre vilkårlig kode hvis misdannet inddata blev overført fra et program.

  • CVE-2007-1380

    Stefan Esser opdagede at sessionshåndteren udførte utilstrækkelig kontrol af variabelnavnes længdeværdier, hvilket muliggjorde informationsafsløring gennem en heap-informationslækage.

  • CVE-2007-1521

    Stefan Esser opdagede en dobbelt frigivelses-sårbarhed i funktionen session_regenerate_id(), hvilket muliggjorde udførelse af vilkårlig kode.

  • CVE-2007-1711

    Stefan Esser opdagede en dobbelt frigivelses-sårbarhed i sessionshåndteringskoden, hvilket muliggjorde udførelse af vilkårlig kode.

  • CVE-2007-1718

    Stefan Esser opdagede at funktionen mail() udførte utilstrækkelig kontrol af foldede mailheadere, hvilket muliggjorde mailheader-indsprøjtning.

  • CVE-2007-1777

    Stefan Esser opdagede at udvidelsen til håndtering af ZIP-arkiv udførte utilstrækkelig længdekontroller, hvilket muliggjorde udførelse af vilkårlig kode.

I den gamle stabile distribution (sarge) er disse problemer rettet i version 4.3.10-20.

I den stabile distribution (etch) er disse problemer rettet i version 4.4.4-8+etch2.

I den ustabile distribution (sid) er disse problemer rettet i version 4.4.6-1. php4 vil blive fjernet fra sid; dermed opfordres du kraftigt til at migrere til php5, hvis du foretrækker at anvende den ustabile distribution.

Vi anbefaler at du opgraderer dine PHP-pakker. Pakker til arkitekturerne arm, m68k, mips og mipsel er endnu ikke tilgængelige. De vil senere blive stillet til rådighed.

Rettet i:

Debian GNU/Linux 3.1 (sarge)

Kildekode:
http://security.debian.org/pool/updates/main/p/php4/php4_4.3.10-20.dsc
http://security.debian.org/pool/updates/main/p/php4/php4_4.3.10-20.diff.gz
http://security.debian.org/pool/updates/main/p/php4/php4_4.3.10.orig.tar.gz
Arkitekturuafhængig komponent:
http://security.debian.org/pool/updates/main/p/php4/php4-pear_4.3.10-20_all.deb
http://security.debian.org/pool/updates/main/p/php4/php4_4.3.10-20_all.deb
Alpha:
http://security.debian.org/pool/updates/main/p/php4/libapache-mod-php4_4.3.10-20_alpha.deb
http://security.debian.org/pool/updates/main/p/php4/libapache2-mod-php4_4.3.10-20_alpha.deb
http://security.debian.org/pool/updates/main/p/php4/php4-cgi_4.3.10-20_alpha.deb
http://security.debian.org/pool/updates/main/p/php4/php4-cli_4.3.10-20_alpha.deb
http://security.debian.org/pool/updates/main/p/php4/php4-common_4.3.10-20_alpha.deb
http://security.debian.org/pool/updates/main/p/php4/php4-curl_4.3.10-20_alpha.deb
http://security.debian.org/pool/updates/main/p/php4/php4-dev_4.3.10-20_alpha.deb
http://security.debian.org/pool/updates/main/p/php4/php4-domxml_4.3.10-20_alpha.deb
http://security.debian.org/pool/updates/main/p/php4/php4-gd_4.3.10-20_alpha.deb
http://security.debian.org/pool/updates/main/p/php4/php4-imap_4.3.10-20_alpha.deb
http://security.debian.org/pool/updates/main/p/php4/php4-ldap_4.3.10-20_alpha.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mcal_4.3.10-20_alpha.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mhash_4.3.10-20_alpha.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mysql_4.3.10-20_alpha.deb
http://security.debian.org/pool/updates/main/p/php4/php4-odbc_4.3.10-20_alpha.deb
http://security.debian.org/pool/updates/main/p/php4/php4-recode_4.3.10-20_alpha.deb
http://security.debian.org/pool/updates/main/p/php4/php4-snmp_4.3.10-20_alpha.deb
http://security.debian.org/pool/updates/main/p/php4/php4-sybase_4.3.10-20_alpha.deb
http://security.debian.org/pool/updates/main/p/php4/php4-xslt_4.3.10-20_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/p/php4/libapache-mod-php4_4.3.10-20_amd64.deb
http://security.debian.org/pool/updates/main/p/php4/libapache2-mod-php4_4.3.10-20_amd64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-cgi_4.3.10-20_amd64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-cli_4.3.10-20_amd64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-common_4.3.10-20_amd64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-curl_4.3.10-20_amd64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-dev_4.3.10-20_amd64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-domxml_4.3.10-20_amd64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-gd_4.3.10-20_amd64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-imap_4.3.10-20_amd64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-ldap_4.3.10-20_amd64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mcal_4.3.10-20_amd64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mhash_4.3.10-20_amd64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mysql_4.3.10-20_amd64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-odbc_4.3.10-20_amd64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-recode_4.3.10-20_amd64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-snmp_4.3.10-20_amd64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-sybase_4.3.10-20_amd64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-xslt_4.3.10-20_amd64.deb
HPPA:
http://security.debian.org/pool/updates/main/p/php4/libapache-mod-php4_4.3.10-20_hppa.deb
http://security.debian.org/pool/updates/main/p/php4/libapache2-mod-php4_4.3.10-20_hppa.deb
http://security.debian.org/pool/updates/main/p/php4/php4-cgi_4.3.10-20_hppa.deb
http://security.debian.org/pool/updates/main/p/php4/php4-cli_4.3.10-20_hppa.deb
http://security.debian.org/pool/updates/main/p/php4/php4-common_4.3.10-20_hppa.deb
http://security.debian.org/pool/updates/main/p/php4/php4-curl_4.3.10-20_hppa.deb
http://security.debian.org/pool/updates/main/p/php4/php4-dev_4.3.10-20_hppa.deb
http://security.debian.org/pool/updates/main/p/php4/php4-domxml_4.3.10-20_hppa.deb
http://security.debian.org/pool/updates/main/p/php4/php4-gd_4.3.10-20_hppa.deb
http://security.debian.org/pool/updates/main/p/php4/php4-imap_4.3.10-20_hppa.deb
http://security.debian.org/pool/updates/main/p/php4/php4-ldap_4.3.10-20_hppa.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mcal_4.3.10-20_hppa.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mhash_4.3.10-20_hppa.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mysql_4.3.10-20_hppa.deb
http://security.debian.org/pool/updates/main/p/php4/php4-odbc_4.3.10-20_hppa.deb
http://security.debian.org/pool/updates/main/p/php4/php4-recode_4.3.10-20_hppa.deb
http://security.debian.org/pool/updates/main/p/php4/php4-snmp_4.3.10-20_hppa.deb
http://security.debian.org/pool/updates/main/p/php4/php4-sybase_4.3.10-20_hppa.deb
http://security.debian.org/pool/updates/main/p/php4/php4-xslt_4.3.10-20_hppa.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/p/php4/libapache-mod-php4_4.3.10-20_i386.deb
http://security.debian.org/pool/updates/main/p/php4/libapache2-mod-php4_4.3.10-20_i386.deb
http://security.debian.org/pool/updates/main/p/php4/php4-cgi_4.3.10-20_i386.deb
http://security.debian.org/pool/updates/main/p/php4/php4-cli_4.3.10-20_i386.deb
http://security.debian.org/pool/updates/main/p/php4/php4-common_4.3.10-20_i386.deb
http://security.debian.org/pool/updates/main/p/php4/php4-curl_4.3.10-20_i386.deb
http://security.debian.org/pool/updates/main/p/php4/php4-dev_4.3.10-20_i386.deb
http://security.debian.org/pool/updates/main/p/php4/php4-domxml_4.3.10-20_i386.deb
http://security.debian.org/pool/updates/main/p/php4/php4-gd_4.3.10-20_i386.deb
http://security.debian.org/pool/updates/main/p/php4/php4-imap_4.3.10-20_i386.deb
http://security.debian.org/pool/updates/main/p/php4/php4-ldap_4.3.10-20_i386.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mcal_4.3.10-20_i386.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mhash_4.3.10-20_i386.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mysql_4.3.10-20_i386.deb
http://security.debian.org/pool/updates/main/p/php4/php4-odbc_4.3.10-20_i386.deb
http://security.debian.org/pool/updates/main/p/php4/php4-recode_4.3.10-20_i386.deb
http://security.debian.org/pool/updates/main/p/php4/php4-snmp_4.3.10-20_i386.deb
http://security.debian.org/pool/updates/main/p/php4/php4-sybase_4.3.10-20_i386.deb
http://security.debian.org/pool/updates/main/p/php4/php4-xslt_4.3.10-20_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/p/php4/libapache-mod-php4_4.3.10-20_ia64.deb
http://security.debian.org/pool/updates/main/p/php4/libapache2-mod-php4_4.3.10-20_ia64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-cgi_4.3.10-20_ia64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-cli_4.3.10-20_ia64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-common_4.3.10-20_ia64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-curl_4.3.10-20_ia64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-dev_4.3.10-20_ia64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-domxml_4.3.10-20_ia64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-gd_4.3.10-20_ia64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-imap_4.3.10-20_ia64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-ldap_4.3.10-20_ia64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mcal_4.3.10-20_ia64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mhash_4.3.10-20_ia64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mysql_4.3.10-20_ia64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-odbc_4.3.10-20_ia64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-recode_4.3.10-20_ia64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-snmp_4.3.10-20_ia64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-sybase_4.3.10-20_ia64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-xslt_4.3.10-20_ia64.deb
PowerPC:
http://security.debian.org/pool/updates/main/p/php4/libapache-mod-php4_4.3.10-20_powerpc.deb
http://security.debian.org/pool/updates/main/p/php4/libapache2-mod-php4_4.3.10-20_powerpc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-cgi_4.3.10-20_powerpc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-cli_4.3.10-20_powerpc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-common_4.3.10-20_powerpc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-curl_4.3.10-20_powerpc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-dev_4.3.10-20_powerpc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-domxml_4.3.10-20_powerpc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-gd_4.3.10-20_powerpc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-imap_4.3.10-20_powerpc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-ldap_4.3.10-20_powerpc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mcal_4.3.10-20_powerpc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mhash_4.3.10-20_powerpc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mysql_4.3.10-20_powerpc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-odbc_4.3.10-20_powerpc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-recode_4.3.10-20_powerpc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-snmp_4.3.10-20_powerpc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-sybase_4.3.10-20_powerpc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-xslt_4.3.10-20_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/p/php4/libapache-mod-php4_4.3.10-20_s390.deb
http://security.debian.org/pool/updates/main/p/php4/libapache2-mod-php4_4.3.10-20_s390.deb
http://security.debian.org/pool/updates/main/p/php4/php4-cgi_4.3.10-20_s390.deb
http://security.debian.org/pool/updates/main/p/php4/php4-cli_4.3.10-20_s390.deb
http://security.debian.org/pool/updates/main/p/php4/php4-common_4.3.10-20_s390.deb
http://security.debian.org/pool/updates/main/p/php4/php4-curl_4.3.10-20_s390.deb
http://security.debian.org/pool/updates/main/p/php4/php4-dev_4.3.10-20_s390.deb
http://security.debian.org/pool/updates/main/p/php4/php4-domxml_4.3.10-20_s390.deb
http://security.debian.org/pool/updates/main/p/php4/php4-gd_4.3.10-20_s390.deb
http://security.debian.org/pool/updates/main/p/php4/php4-imap_4.3.10-20_s390.deb
http://security.debian.org/pool/updates/main/p/php4/php4-ldap_4.3.10-20_s390.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mcal_4.3.10-20_s390.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mhash_4.3.10-20_s390.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mysql_4.3.10-20_s390.deb
http://security.debian.org/pool/updates/main/p/php4/php4-odbc_4.3.10-20_s390.deb
http://security.debian.org/pool/updates/main/p/php4/php4-recode_4.3.10-20_s390.deb
http://security.debian.org/pool/updates/main/p/php4/php4-snmp_4.3.10-20_s390.deb
http://security.debian.org/pool/updates/main/p/php4/php4-sybase_4.3.10-20_s390.deb
http://security.debian.org/pool/updates/main/p/php4/php4-xslt_4.3.10-20_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/p/php4/libapache-mod-php4_4.3.10-20_sparc.deb
http://security.debian.org/pool/updates/main/p/php4/libapache2-mod-php4_4.3.10-20_sparc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-cgi_4.3.10-20_sparc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-cli_4.3.10-20_sparc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-common_4.3.10-20_sparc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-curl_4.3.10-20_sparc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-dev_4.3.10-20_sparc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-domxml_4.3.10-20_sparc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-gd_4.3.10-20_sparc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-imap_4.3.10-20_sparc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-ldap_4.3.10-20_sparc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mcal_4.3.10-20_sparc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mhash_4.3.10-20_sparc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mysql_4.3.10-20_sparc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-odbc_4.3.10-20_sparc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-recode_4.3.10-20_sparc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-snmp_4.3.10-20_sparc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-sybase_4.3.10-20_sparc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-xslt_4.3.10-20_sparc.deb

Debian GNU/Linux 4.0 (etch)

Kildekode:
http://security.debian.org/pool/updates/main/p/php4/php4_4.4.4-8+etch2.dsc
http://security.debian.org/pool/updates/main/p/php4/php4_4.4.4-8+etch2.diff.gz
http://security.debian.org/pool/updates/main/p/php4/php4_4.4.4.orig.tar.gz
Arkitekturuafhængig komponent:
http://security.debian.org/pool/updates/main/p/php4/php4-pear_4.4.4-8+etch2_all.deb
http://security.debian.org/pool/updates/main/p/php4/php4_4.4.4-8+etch2_all.deb
Alpha:
http://security.debian.org/pool/updates/main/p/php4/libapache-mod-php4_4.4.4-8+etch2_alpha.deb
http://security.debian.org/pool/updates/main/p/php4/libapache2-mod-php4_4.4.4-8+etch2_alpha.deb
http://security.debian.org/pool/updates/main/p/php4/php4-cgi_4.4.4-8+etch2_alpha.deb
http://security.debian.org/pool/updates/main/p/php4/php4-cli_4.4.4-8+etch2_alpha.deb
http://security.debian.org/pool/updates/main/p/php4/php4-common_4.4.4-8+etch2_alpha.deb
http://security.debian.org/pool/updates/main/p/php4/php4-curl_4.4.4-8+etch2_alpha.deb
http://security.debian.org/pool/updates/main/p/php4/php4-dev_4.4.4-8+etch2_alpha.deb
http://security.debian.org/pool/updates/main/p/php4/php4-domxml_4.4.4-8+etch2_alpha.deb
http://security.debian.org/pool/updates/main/p/php4/php4-gd_4.4.4-8+etch2_alpha.deb
http://security.debian.org/pool/updates/main/p/php4/php4-imap_4.4.4-8+etch2_alpha.deb
http://security.debian.org/pool/updates/main/p/php4/php4-ldap_4.4.4-8+etch2_alpha.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mcal_4.4.4-8+etch2_alpha.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mcrypt_4.4.4-8+etch2_alpha.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mhash_4.4.4-8+etch2_alpha.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mysql_4.4.4-8+etch2_alpha.deb
http://security.debian.org/pool/updates/main/p/php4/php4-odbc_4.4.4-8+etch2_alpha.deb
http://security.debian.org/pool/updates/main/p/php4/php4-pgsql_4.4.4-8+etch2_alpha.deb
http://security.debian.org/pool/updates/main/p/php4/php4-pspell_4.4.4-8+etch2_alpha.deb
http://security.debian.org/pool/updates/main/p/php4/php4-recode_4.4.4-8+etch2_alpha.deb
http://security.debian.org/pool/updates/main/p/php4/php4-snmp_4.4.4-8+etch2_alpha.deb
http://security.debian.org/pool/updates/main/p/php4/php4-sybase_4.4.4-8+etch2_alpha.deb
http://security.debian.org/pool/updates/main/p/php4/php4-xslt_4.4.4-8+etch2_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/p/php4/libapache-mod-php4_4.4.4-8+etch2_amd64.deb
http://security.debian.org/pool/updates/main/p/php4/libapache2-mod-php4_4.4.4-8+etch2_amd64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-cgi_4.4.4-8+etch2_amd64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-cli_4.4.4-8+etch2_amd64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-common_4.4.4-8+etch2_amd64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-curl_4.4.4-8+etch2_amd64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-dev_4.4.4-8+etch2_amd64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-domxml_4.4.4-8+etch2_amd64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-gd_4.4.4-8+etch2_amd64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-imap_4.4.4-8+etch2_amd64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-interbase_4.4.4-8+etch2_amd64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-ldap_4.4.4-8+etch2_amd64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mcal_4.4.4-8+etch2_amd64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mcrypt_4.4.4-8+etch2_amd64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mhash_4.4.4-8+etch2_amd64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mysql_4.4.4-8+etch2_amd64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-odbc_4.4.4-8+etch2_amd64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-pgsql_4.4.4-8+etch2_amd64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-pspell_4.4.4-8+etch2_amd64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-recode_4.4.4-8+etch2_amd64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-snmp_4.4.4-8+etch2_amd64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-sybase_4.4.4-8+etch2_amd64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-xslt_4.4.4-8+etch2_amd64.deb
HPPA:
http://security.debian.org/pool/updates/main/p/php4/libapache-mod-php4_4.4.4-8+etch2_hppa.deb
http://security.debian.org/pool/updates/main/p/php4/libapache2-mod-php4_4.4.4-8+etch2_hppa.deb
http://security.debian.org/pool/updates/main/p/php4/php4-cgi_4.4.4-8+etch2_hppa.deb
http://security.debian.org/pool/updates/main/p/php4/php4-cli_4.4.4-8+etch2_hppa.deb
http://security.debian.org/pool/updates/main/p/php4/php4-common_4.4.4-8+etch2_hppa.deb
http://security.debian.org/pool/updates/main/p/php4/php4-curl_4.4.4-8+etch2_hppa.deb
http://security.debian.org/pool/updates/main/p/php4/php4-dev_4.4.4-8+etch2_hppa.deb
http://security.debian.org/pool/updates/main/p/php4/php4-domxml_4.4.4-8+etch2_hppa.deb
http://security.debian.org/pool/updates/main/p/php4/php4-gd_4.4.4-8+etch2_hppa.deb
http://security.debian.org/pool/updates/main/p/php4/php4-imap_4.4.4-8+etch2_hppa.deb
http://security.debian.org/pool/updates/main/p/php4/php4-ldap_4.4.4-8+etch2_hppa.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mcal_4.4.4-8+etch2_hppa.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mcrypt_4.4.4-8+etch2_hppa.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mhash_4.4.4-8+etch2_hppa.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mysql_4.4.4-8+etch2_hppa.deb
http://security.debian.org/pool/updates/main/p/php4/php4-odbc_4.4.4-8+etch2_hppa.deb
http://security.debian.org/pool/updates/main/p/php4/php4-pgsql_4.4.4-8+etch2_hppa.deb
http://security.debian.org/pool/updates/main/p/php4/php4-pspell_4.4.4-8+etch2_hppa.deb
http://security.debian.org/pool/updates/main/p/php4/php4-recode_4.4.4-8+etch2_hppa.deb
http://security.debian.org/pool/updates/main/p/php4/php4-snmp_4.4.4-8+etch2_hppa.deb
http://security.debian.org/pool/updates/main/p/php4/php4-sybase_4.4.4-8+etch2_hppa.deb
http://security.debian.org/pool/updates/main/p/php4/php4-xslt_4.4.4-8+etch2_hppa.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/p/php4/libapache-mod-php4_4.4.4-8+etch2_i386.deb
http://security.debian.org/pool/updates/main/p/php4/libapache2-mod-php4_4.4.4-8+etch2_i386.deb
http://security.debian.org/pool/updates/main/p/php4/php4-cgi_4.4.4-8+etch2_i386.deb
http://security.debian.org/pool/updates/main/p/php4/php4-cli_4.4.4-8+etch2_i386.deb
http://security.debian.org/pool/updates/main/p/php4/php4-common_4.4.4-8+etch2_i386.deb
http://security.debian.org/pool/updates/main/p/php4/php4-curl_4.4.4-8+etch2_i386.deb
http://security.debian.org/pool/updates/main/p/php4/php4-dev_4.4.4-8+etch2_i386.deb
http://security.debian.org/pool/updates/main/p/php4/php4-domxml_4.4.4-8+etch2_i386.deb
http://security.debian.org/pool/updates/main/p/php4/php4-gd_4.4.4-8+etch2_i386.deb
http://security.debian.org/pool/updates/main/p/php4/php4-imap_4.4.4-8+etch2_i386.deb
http://security.debian.org/pool/updates/main/p/php4/php4-interbase_4.4.4-8+etch2_i386.deb
http://security.debian.org/pool/updates/main/p/php4/php4-ldap_4.4.4-8+etch2_i386.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mcal_4.4.4-8+etch2_i386.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mcrypt_4.4.4-8+etch2_i386.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mhash_4.4.4-8+etch2_i386.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mysql_4.4.4-8+etch2_i386.deb
http://security.debian.org/pool/updates/main/p/php4/php4-odbc_4.4.4-8+etch2_i386.deb
http://security.debian.org/pool/updates/main/p/php4/php4-pgsql_4.4.4-8+etch2_i386.deb
http://security.debian.org/pool/updates/main/p/php4/php4-pspell_4.4.4-8+etch2_i386.deb
http://security.debian.org/pool/updates/main/p/php4/php4-recode_4.4.4-8+etch2_i386.deb
http://security.debian.org/pool/updates/main/p/php4/php4-snmp_4.4.4-8+etch2_i386.deb
http://security.debian.org/pool/updates/main/p/php4/php4-sybase_4.4.4-8+etch2_i386.deb
http://security.debian.org/pool/updates/main/p/php4/php4-xslt_4.4.4-8+etch2_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/p/php4/libapache-mod-php4_4.4.4-8+etch2_ia64.deb
http://security.debian.org/pool/updates/main/p/php4/libapache2-mod-php4_4.4.4-8+etch2_ia64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-cgi_4.4.4-8+etch2_ia64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-cli_4.4.4-8+etch2_ia64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-common_4.4.4-8+etch2_ia64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-curl_4.4.4-8+etch2_ia64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-dev_4.4.4-8+etch2_ia64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-domxml_4.4.4-8+etch2_ia64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-gd_4.4.4-8+etch2_ia64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-imap_4.4.4-8+etch2_ia64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-ldap_4.4.4-8+etch2_ia64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mcal_4.4.4-8+etch2_ia64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mcrypt_4.4.4-8+etch2_ia64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mhash_4.4.4-8+etch2_ia64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mysql_4.4.4-8+etch2_ia64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-odbc_4.4.4-8+etch2_ia64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-pgsql_4.4.4-8+etch2_ia64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-pspell_4.4.4-8+etch2_ia64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-recode_4.4.4-8+etch2_ia64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-snmp_4.4.4-8+etch2_ia64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-sybase_4.4.4-8+etch2_ia64.deb
http://security.debian.org/pool/updates/main/p/php4/php4-xslt_4.4.4-8+etch2_ia64.deb
PowerPC:
http://security.debian.org/pool/updates/main/p/php4/libapache-mod-php4_4.4.4-8+etch2_powerpc.deb
http://security.debian.org/pool/updates/main/p/php4/libapache2-mod-php4_4.4.4-8+etch2_powerpc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-cgi_4.4.4-8+etch2_powerpc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-cli_4.4.4-8+etch2_powerpc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-common_4.4.4-8+etch2_powerpc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-curl_4.4.4-8+etch2_powerpc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-dev_4.4.4-8+etch2_powerpc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-domxml_4.4.4-8+etch2_powerpc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-gd_4.4.4-8+etch2_powerpc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-imap_4.4.4-8+etch2_powerpc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-ldap_4.4.4-8+etch2_powerpc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mcal_4.4.4-8+etch2_powerpc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mcrypt_4.4.4-8+etch2_powerpc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mhash_4.4.4-8+etch2_powerpc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mysql_4.4.4-8+etch2_powerpc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-odbc_4.4.4-8+etch2_powerpc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-pgsql_4.4.4-8+etch2_powerpc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-pspell_4.4.4-8+etch2_powerpc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-recode_4.4.4-8+etch2_powerpc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-snmp_4.4.4-8+etch2_powerpc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-sybase_4.4.4-8+etch2_powerpc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-xslt_4.4.4-8+etch2_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/p/php4/libapache-mod-php4_4.4.4-8+etch2_s390.deb
http://security.debian.org/pool/updates/main/p/php4/libapache2-mod-php4_4.4.4-8+etch2_s390.deb
http://security.debian.org/pool/updates/main/p/php4/php4-cgi_4.4.4-8+etch2_s390.deb
http://security.debian.org/pool/updates/main/p/php4/php4-cli_4.4.4-8+etch2_s390.deb
http://security.debian.org/pool/updates/main/p/php4/php4-common_4.4.4-8+etch2_s390.deb
http://security.debian.org/pool/updates/main/p/php4/php4-curl_4.4.4-8+etch2_s390.deb
http://security.debian.org/pool/updates/main/p/php4/php4-dev_4.4.4-8+etch2_s390.deb
http://security.debian.org/pool/updates/main/p/php4/php4-domxml_4.4.4-8+etch2_s390.deb
http://security.debian.org/pool/updates/main/p/php4/php4-gd_4.4.4-8+etch2_s390.deb
http://security.debian.org/pool/updates/main/p/php4/php4-imap_4.4.4-8+etch2_s390.deb
http://security.debian.org/pool/updates/main/p/php4/php4-ldap_4.4.4-8+etch2_s390.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mcal_4.4.4-8+etch2_s390.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mcrypt_4.4.4-8+etch2_s390.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mhash_4.4.4-8+etch2_s390.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mysql_4.4.4-8+etch2_s390.deb
http://security.debian.org/pool/updates/main/p/php4/php4-odbc_4.4.4-8+etch2_s390.deb
http://security.debian.org/pool/updates/main/p/php4/php4-pgsql_4.4.4-8+etch2_s390.deb
http://security.debian.org/pool/updates/main/p/php4/php4-pspell_4.4.4-8+etch2_s390.deb
http://security.debian.org/pool/updates/main/p/php4/php4-recode_4.4.4-8+etch2_s390.deb
http://security.debian.org/pool/updates/main/p/php4/php4-snmp_4.4.4-8+etch2_s390.deb
http://security.debian.org/pool/updates/main/p/php4/php4-sybase_4.4.4-8+etch2_s390.deb
http://security.debian.org/pool/updates/main/p/php4/php4-xslt_4.4.4-8+etch2_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/p/php4/libapache-mod-php4_4.4.4-8+etch2_sparc.deb
http://security.debian.org/pool/updates/main/p/php4/libapache2-mod-php4_4.4.4-8+etch2_sparc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-cgi_4.4.4-8+etch2_sparc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-cli_4.4.4-8+etch2_sparc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-common_4.4.4-8+etch2_sparc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-curl_4.4.4-8+etch2_sparc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-dev_4.4.4-8+etch2_sparc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-domxml_4.4.4-8+etch2_sparc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-gd_4.4.4-8+etch2_sparc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-imap_4.4.4-8+etch2_sparc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-ldap_4.4.4-8+etch2_sparc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mcal_4.4.4-8+etch2_sparc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mcrypt_4.4.4-8+etch2_sparc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mhash_4.4.4-8+etch2_sparc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-mysql_4.4.4-8+etch2_sparc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-odbc_4.4.4-8+etch2_sparc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-pgsql_4.4.4-8+etch2_sparc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-pspell_4.4.4-8+etch2_sparc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-recode_4.4.4-8+etch2_sparc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-snmp_4.4.4-8+etch2_sparc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-sybase_4.4.4-8+etch2_sparc.deb
http://security.debian.org/pool/updates/main/p/php4/php4-xslt_4.4.4-8+etch2_sparc.deb

MD5-kontrolsummer for de listede filer findes i den originale sikkerhedsbulletin.