Debians sikkerhedsbulletin

DSA-1297-1 gforge-plugin-scmcvs -- manglende kontrol af inddata

Rapporteret den:
24. maj 2007
Berørte pakker:
gforge-plugin-scmcvs
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Mitres CVE-ordbog: CVE-2007-0246.
Yderligere oplysninger:

Bernhard R. Link opdagede at CVS-visningsgrænsefladen i Gforge, et samarbejdsudviklingsværktøj, udførte utilstrækkelig indkapsling af URL'er, hvilket gjorde det muligt at udføre vilkårlige shell-kommandoer med rettighederne hørende til brugeren www-data.

Den gamle stabile distribution (sarge) er ikke påvirket af dette problem.

I den stabile distribution (etch) er dette problem rettet i version 4.5.14-5etch1.

I den ustabile distribution (sid) er dette problem rettet i version 4.5.14-6.

Vi anbefaler at du opgraderer din gforge-plugin-scmcvs-pakke.

Rettet i:

Debian GNU/Linux 4.0 (etch)

Kildekode:
http://security.debian.org/pool/updates/main/g/gforge-plugin-scmcvs/gforge-plugin-scmcvs_4.5.14-5etch1.dsc
http://security.debian.org/pool/updates/main/g/gforge-plugin-scmcvs/gforge-plugin-scmcvs_4.5.14-5etch1.tar.gz
Arkitekturuafhængig komponent:
http://security.debian.org/pool/updates/main/g/gforge-plugin-scmcvs/gforge-plugin-scmcvs_4.5.14-5etch1_all.deb

MD5-kontrolsummer for de listede filer findes i den originale sikkerhedsbulletin.