Debian セキュリティ勧告

DSA-1462-1 hplip -- 入力のサニタイズ漏れ

報告日時:
2008-01-13
影響を受けるパッケージ:
hplip
危険性:
あり
参考セキュリティデータベース:
Mitre の CVE 辞書: CVE-2007-5208.
詳細:

Kees Cook さんにより、HP Linux プリンティング/イメージングシステ (HPLIP) が入力時にシェルのメタキャラクタを十分にサニタイズしていないた め、ローカルで hplip ユーザへの権限昇格が可能であることが発見されました。

旧安定版 (sarge) にはこの問題の影響はありません。

安定版 (stable) ディストリビューション (etch) では、この問題はバージョン 1.6.10-3etch1 で修正されています。

不安定版 (unstable) ディストリビューション (sid) では、この問題はバージョ ン 1.6.10-4.3 で修正されています。

直ぐに hplip パッケージをアップグレードすることを勧めます。

修正:

Debian GNU/Linux 4.0 (stable)

ソース:
http://security.debian.org/pool/updates/main/h/hplip/hplip_1.6.10-3etch1.dsc
http://security.debian.org/pool/updates/main/h/hplip/hplip_1.6.10.orig.tar.gz
http://security.debian.org/pool/updates/main/h/hplip/hplip_1.6.10-3etch1.diff.gz
アーキテクチャ非依存コンポーネント:
http://security.debian.org/pool/updates/main/h/hplip/hpijs-ppds_2.6.10+1.6.10-3etch1_all.deb
http://security.debian.org/pool/updates/main/h/hplip/hplip-data_1.6.10-3etch1_all.deb
http://security.debian.org/pool/updates/main/h/hplip/hplip-doc_1.6.10-3etch1_all.deb
Alpha:
http://security.debian.org/pool/updates/main/h/hplip/hplip-dbg_1.6.10-3etch1_alpha.deb
http://security.debian.org/pool/updates/main/h/hplip/hplip_1.6.10-3etch1_alpha.deb
http://security.debian.org/pool/updates/main/h/hplip/hpijs_2.6.10+1.6.10-3etch1_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/h/hplip/hpijs_2.6.10+1.6.10-3etch1_amd64.deb
http://security.debian.org/pool/updates/main/h/hplip/hplip_1.6.10-3etch1_amd64.deb
http://security.debian.org/pool/updates/main/h/hplip/hplip-dbg_1.6.10-3etch1_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/h/hplip/hpijs_2.6.10+1.6.10-3etch1_arm.deb
http://security.debian.org/pool/updates/main/h/hplip/hplip_1.6.10-3etch1_arm.deb
http://security.debian.org/pool/updates/main/h/hplip/hplip-dbg_1.6.10-3etch1_arm.deb
HP Precision:
http://security.debian.org/pool/updates/main/h/hplip/hpijs_2.6.10+1.6.10-3etch1_hppa.deb
http://security.debian.org/pool/updates/main/h/hplip/hplip_1.6.10-3etch1_hppa.deb
http://security.debian.org/pool/updates/main/h/hplip/hplip-dbg_1.6.10-3etch1_hppa.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/h/hplip/hpijs_2.6.10+1.6.10-3etch1_i386.deb
http://security.debian.org/pool/updates/main/h/hplip/hplip_1.6.10-3etch1_i386.deb
http://security.debian.org/pool/updates/main/h/hplip/hplip-dbg_1.6.10-3etch1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/h/hplip/hplip-dbg_1.6.10-3etch1_ia64.deb
http://security.debian.org/pool/updates/main/h/hplip/hplip_1.6.10-3etch1_ia64.deb
http://security.debian.org/pool/updates/main/h/hplip/hpijs_2.6.10+1.6.10-3etch1_ia64.deb
Big-endian MIPS:
http://security.debian.org/pool/updates/main/h/hplip/hplip-dbg_1.6.10-3etch1_mips.deb
http://security.debian.org/pool/updates/main/h/hplip/hplip_1.6.10-3etch1_mips.deb
http://security.debian.org/pool/updates/main/h/hplip/hpijs_2.6.10+1.6.10-3etch1_mips.deb
Little-endian MIPS:
http://security.debian.org/pool/updates/main/h/hplip/hplip_1.6.10-3etch1_mipsel.deb
http://security.debian.org/pool/updates/main/h/hplip/hplip-dbg_1.6.10-3etch1_mipsel.deb
http://security.debian.org/pool/updates/main/h/hplip/hpijs_2.6.10+1.6.10-3etch1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/h/hplip/hplip-dbg_1.6.10-3etch1_powerpc.deb
http://security.debian.org/pool/updates/main/h/hplip/hplip_1.6.10-3etch1_powerpc.deb
http://security.debian.org/pool/updates/main/h/hplip/hpijs_2.6.10+1.6.10-3etch1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/h/hplip/hplip_1.6.10-3etch1_s390.deb
http://security.debian.org/pool/updates/main/h/hplip/hpijs_2.6.10+1.6.10-3etch1_s390.deb
http://security.debian.org/pool/updates/main/h/hplip/hplip-dbg_1.6.10-3etch1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/h/hplip/hplip_1.6.10-3etch1_sparc.deb
http://security.debian.org/pool/updates/main/h/hplip/hpijs_2.6.10+1.6.10-3etch1_sparc.deb
http://security.debian.org/pool/updates/main/h/hplip/hplip-dbg_1.6.10-3etch1_sparc.deb

一覧にあるファイルの MD5 チェックサムは勧告の原文にあります。