Debian-Sicherheitsankündigung

DSA-1486-1 gnatsweb -- Site-übergreifendes Skripting

Datum des Berichts:
04. Feb 2008
Betroffene Pakete:
gnatsweb
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In der Debian-Fehlerdatenbank: Fehler 427156.
In Mitres CVE-Verzeichnis: CVE-2007-2808.
Weitere Informationen:

r0t entdeckte, dass gnatsweb, eine Web-Schnittstelle zu GNU GNATS, Datenbank-Parameter im Haupt-CGI-Skript nicht korrekt bereinigt. Dies könnte die Einschleusung beliebigen HTML- oder JavaScript-Codes ermöglichen.

Für die Stable-Distribution (Etch) wurde dieses Problem in Version 4.00-1etch1 behoben.

Wir empfehlen Ihnen, Ihr gnatsweb-Paket zu aktualisieren.

Behoben in:

Debian GNU/Linux 4.0 (etch)

Quellcode:
http://security.debian.org/pool/updates/main/g/gnatsweb/gnatsweb_4.00-1etch1.dsc
http://security.debian.org/pool/updates/main/g/gnatsweb/gnatsweb_4.00.orig.tar.gz
http://security.debian.org/pool/updates/main/g/gnatsweb/gnatsweb_4.00-1etch1.diff.gz
Architektur-unabhängige Dateien:
http://security.debian.org/pool/updates/main/g/gnatsweb/gnatsweb_4.00-1etch1_all.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.