Bulletin d'alerte Debian

DSA-1559-1 phpgedview -- Validation d'entrée manquante

Date du rapport :
27 avril 2008
Paquets concernés :
phpgedview
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 443901.
Dans le dictionnaire CVE du Mitre : CVE-2007-5051.
Plus de précisions :

On a découvert que phpGedView, une application pour fournir un accès en ligne des données généalogiques, ne réalisait pas de validation suffisante des entrées sur certains paramètres. Cela la rend vulnérable à des attaques par script intersite.

Pour la distribution stable (Etch), ce problème a été corrigé dans la version 4.0.2.dfsg-3.

Pour la distribution instable (Sid), ce problème a été corrigé dans la version 4.1.e+4.1.1-2.

Nous vous recommandons de mettre à jour votre paquet phpgedview.

Corrigé dans :

Debian GNU/Linux 4.0 (etch)

Source :
http://security.debian.org/pool/updates/main/p/phpgedview/phpgedview_4.0.2.dfsg.orig.tar.gz
http://security.debian.org/pool/updates/main/p/phpgedview/phpgedview_4.0.2.dfsg-3.diff.gz
http://security.debian.org/pool/updates/main/p/phpgedview/phpgedview_4.0.2.dfsg-3.dsc
Composant indépendant de l'architecture :
http://security.debian.org/pool/updates/main/p/phpgedview/phpgedview-themes_4.0.2.dfsg-3_all.deb
http://security.debian.org/pool/updates/main/p/phpgedview/phpgedview-places_4.0.2.dfsg-3_all.deb
http://security.debian.org/pool/updates/main/p/phpgedview/phpgedview_4.0.2.dfsg-3_all.deb
http://security.debian.org/pool/updates/main/p/phpgedview/phpgedview-languages_4.0.2.dfsg-3_all.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.