Рекомендация Debian по безопасности

DSA-1559-1 phpgedview -- недостаточная очистка ввода

Дата сообщения:
27.04.2008
Затронутые пакеты:
phpgedview
Уязвим:
Да
Ссылки на базы данных по безопасности:
В системе отслеживания ошибок Debian: Ошибка 443901.
В каталоге Mitre CVE: CVE-2007-5051.
Более подробная информация:

Было обнаружено, что phpGedView, приложение для предоставления онлайн доступа к генеалогическим данным, выполняет недостаточную очистку ввода при использовании некоторы параметров, что делает его уязвимым к межсайтовому скриптингу.

В стабильном выпуске (etch) эта проблема была исправлена в версии 4.0.2.dfsg-3.

В нестабильном выпуске (sid) эта проблема была исправлена в версии 4.1.e+4.1.1-2.

Рекомендуется обновить пакет phpgedview.

Исправлено в:

Debian GNU/Linux 4.0 (etch)

Исходный код:
http://security.debian.org/pool/updates/main/p/phpgedview/phpgedview_4.0.2.dfsg.orig.tar.gz
http://security.debian.org/pool/updates/main/p/phpgedview/phpgedview_4.0.2.dfsg-3.diff.gz
http://security.debian.org/pool/updates/main/p/phpgedview/phpgedview_4.0.2.dfsg-3.dsc
Независимые от архитектуры компоненты:
http://security.debian.org/pool/updates/main/p/phpgedview/phpgedview-themes_4.0.2.dfsg-3_all.deb
http://security.debian.org/pool/updates/main/p/phpgedview/phpgedview-places_4.0.2.dfsg-3_all.deb
http://security.debian.org/pool/updates/main/p/phpgedview/phpgedview_4.0.2.dfsg-3_all.deb
http://security.debian.org/pool/updates/main/p/phpgedview/phpgedview-languages_4.0.2.dfsg-3_all.deb

Контрольные суммы MD5 этих файлов доступны в исходном сообщении.