Debian セキュリティ勧告

DSA-1611-1 afuse -- 特権の昇格

報告日時:
2008-07-16
影響を受けるパッケージ:
afuse
危険性:
あり
参考セキュリティデータベース:
Debian バグ追跡システム: バグ 490921.
Mitre の CVE 辞書: CVE-2008-2232.
詳細:

Anders Kaseorg さんにより、ユーザ空間で自動マウントするファイルシステ afuse がパスのメタキャラクタを適切にエスケープしていないことが発見されま した。これにより、ファイルシステムの読み出し権限のあるローカルの攻撃者が、 ファイルシステムのオーナ権限で任意のコードを実行可能です。

安定版 (stable) ディストリビューション (etch) では、この問題はバージョン 0.1.1-1+etch1 で修正されています。

不安定版 (unstable) ディストリビューション (sid) では、この問題はバージョ ン 0.2-3 で修正されています。

直ぐに afuse (0.1.1-1+etch1) パッケージをアップグレードすることを勧めます。

修正:

Debian GNU/Linux 4.0 (etch)

ソース:
http://security.debian.org/pool/updates/main/a/afuse/afuse_0.1.1-1+etch1.diff.gz
http://security.debian.org/pool/updates/main/a/afuse/afuse_0.1.1-1+etch1.dsc
http://security.debian.org/pool/updates/main/a/afuse/afuse_0.1.1.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/a/afuse/afuse_0.1.1-1+etch1_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/a/afuse/afuse_0.1.1-1+etch1_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/a/afuse/afuse_0.1.1-1+etch1_arm.deb
HP Precision:
http://security.debian.org/pool/updates/main/a/afuse/afuse_0.1.1-1+etch1_hppa.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/a/afuse/afuse_0.1.1-1+etch1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/a/afuse/afuse_0.1.1-1+etch1_ia64.deb
Big-endian MIPS:
http://security.debian.org/pool/updates/main/a/afuse/afuse_0.1.1-1+etch1_mips.deb
Little-endian MIPS:
http://security.debian.org/pool/updates/main/a/afuse/afuse_0.1.1-1+etch1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/a/afuse/afuse_0.1.1-1+etch1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/a/afuse/afuse_0.1.1-1+etch1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/a/afuse/afuse_0.1.1-1+etch1_sparc.deb

一覧にあるファイルの MD5 チェックサムは勧告の原文にあります。