Рекомендация Debian по безопасности

DSA-1714-1 rt2570 -- переполнение целых чисел

Дата сообщения:
28.01.2009
Затронутые пакеты:
rt2570
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2009-0282.
Более подробная информация:

Было обнаружено, что переполнение целых чисел в коде для грамматического разбора пакетов "Probe Request" из состава драйверов для беспроводных устройств Ralinktech может приводить к удалённому отказу в обслуживании или выполнению произвольного кода.

Заметьте, что вам следует заново собрать драйвер из пакета с исходным кодом для того, чтобы данное обновление начало действовать. Подробные инструкции можно найти в файле /usr/share/doc/rt2570-source/README.Debian

В стабильном выпуске (etch) эта проблема была исправлена в версии 1.1.0+cvs20060620-3+etch1.

В готовящемся стабильном (lenny) и нестабильно (sid) выпусках эта проблема была исправлена в версии 1.1.0+cvs20080623-2.

Рекомендуется обновить пакет rt2570.

Исправлено в:

Debian GNU/Linux 4.0 (etch)

Исходный код:
http://security.debian.org/pool/updates/main/r/rt2570/rt2570_1.1.0+cvs20060620-3+etch1.dsc
http://security.debian.org/pool/updates/main/r/rt2570/rt2570_1.1.0+cvs20060620-3+etch1.diff.gz
http://security.debian.org/pool/updates/main/r/rt2570/rt2570_1.1.0+cvs20060620.orig.tar.gz
Независимые от архитектуры компоненты:
http://security.debian.org/pool/updates/main/r/rt2570/rt2570-source_1.1.0+cvs20060620-3+etch1_all.deb

Контрольные суммы MD5 этих файлов доступны в исходном сообщении.