Debian セキュリティ勧告

DSA-1754-1 roundup -- 不十分なアクセスチェック

報告日時:
2009-04-09
影響を受けるパッケージ:
roundup
危険性:
あり
参考セキュリティデータベース:
Debian バグ追跡システム: バグ 518768.
詳細:

コマンドライン、ウェブおよび電子メールに対応したバグトラックシステ roundup が、ユーザに安全でない方法でのリソースの編集を許しているおり、 管理者権限の取得などが行えることが発見されました。

この更新ではより厳密なアクセスチェックを導入しており、具体的には設定され たパーミッションとロールを厳格に適用するようになっています。このため、設 定ファイルには更新が必要です。さらに、ウェブインターフェース経由のユーザ 登録は無効化されました。代わりにコマンドライン roundup-admin を使ってく ださい。

旧安定版 (oldstable) ディストリビューション (etch) では、この問題はバー ジョン 1.2.1-10+etch1 で修正されています。

安定版 (stable) ディストリビューション (lenny) では、この問題はバージョン 1.4.4-4+lenny1 で修正されています。

直ぐに roundup パッケージをアップグレードすることを勧めます。

修正:

Debian GNU/Linux 4.0 (etch)

ソース:
http://security.debian.org/pool/updates/main/r/roundup/roundup_1.2.1-10+etch1.dsc
http://security.debian.org/pool/updates/main/r/roundup/roundup_1.2.1-10+etch1.diff.gz
アーキテクチャ非依存コンポーネント:
http://security.debian.org/pool/updates/main/r/roundup/roundup_1.2.1-10+etch1_all.deb

Debian GNU/Linux 5.0 (lenny)

ソース:
http://security.debian.org/pool/updates/main/r/roundup/roundup_1.4.4.orig.tar.gz
http://security.debian.org/pool/updates/main/r/roundup/roundup_1.4.4-4+lenny1.diff.gz
http://security.debian.org/pool/updates/main/r/roundup/roundup_1.4.4-4+lenny1.dsc
アーキテクチャ非依存コンポーネント:
http://security.debian.org/pool/updates/main/r/roundup/roundup_1.4.4-4+lenny1_all.deb

一覧にあるファイルの MD5 チェックサムは勧告の原文にあります。