Рекомендация Debian по безопасности

DSA-1764-1 tunapie -- несколько уязвимостей

Дата сообщения:
07.04.2009
Затронутые пакеты:
tunapie
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2009-1253, CVE-2009-1254.
Более подробная информация:

В Tunapie, графическом интерфейсе для видео- и радиовещательных потоков, было обнаружено несколько уязвимостей. Проект Common Vulnerabilities and Exposures определяет следующие проблемы:

  • CVE-2009-1253

    Кис Кук обнаружил, что небезопасная работа с временными файлами может приводить к локальному отказу в обслуживании из-за атаки через символьные ссылки.

  • CVE-2009-1254

    Майк Коулман обнаружил, что недостаточное экранирование URL потоков может приводить к выполнению произвольных команд в случае, если пользователь открывает специально сформированный URL потока.

В предыдущем стабильном выпуске (etch) эти проблемы были исправлены в версии 1.3.1-1+etch2. Из-за технических проблем данное обновление не может быть выпущено одновременно с обновлением стабильного выпуска (lenny), оно появится позже.

В стабильном выпуске (lenny) эти проблемы были исправлены в версии 2.1.8-2.

В нестабильном выпуске (sid) эти проблемы будут исправлены позже.

Рекомендуется обновить пакет tunapie.

Исправлено в:

Debian GNU/Linux 5.0 (lenny)

Исходный код:
http://security.debian.org/pool/updates/main/t/tunapie/tunapie_2.1.8-2.dsc
http://security.debian.org/pool/updates/main/t/tunapie/tunapie_2.1.8.orig.tar.gz
http://security.debian.org/pool/updates/main/t/tunapie/tunapie_2.1.8-2.diff.gz
Независимые от архитектуры компоненты:
http://security.debian.org/pool/updates/main/t/tunapie/tunapie_2.1.8-2_all.deb

Контрольные суммы MD5 этих файлов доступны в исходном сообщении.