Debian Security Advisory

DSA-2015-1 drbd8 -- privilege escalation

Date Reported:
15 Mar 2010
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 573531.
More information:

A local vulnerability has been discovered in drbd8.

Philipp Reisner fixed an issue in the drbd kernel module that allows local users to send netlink packets to perform actions that should be restricted to users with CAP_SYS_ADMIN privileges. This is a similar issue to those described by CVE-2009-3725.

This update also fixes an ABI compatibility issue which was introduced by linux-2.6 (2.6.26-21lenny3). The prebuilt drbd module packages listed in this advisory require a linux-image package version 2.6.26-21lenny3 or greater.

For the stable distribution (lenny), this problem has been fixed in drbd8 (2:8.0.14-2+lenny1).

We recommend that you upgrade your drbd8 packages.

The linux-modules-extra-2.6 package has been rebuilt against the updated drbd8 package to provide fixed prebuilt drbd8-modules packages. If, instead of using the prebuilt drbd8-modules packages, you have built and installed a local copy of the drbd module from the drbd8-source package (e.g., using module-assistant), you will need to follow the same steps you originally used to rebuild your module after upgrading the drbd8-source package.

Note: After upgrading a kernel module you must reload the module for the changes to take effect:

  1. Shutdown all services that make use of the drbd module
  2. Unload the previous drbd module (modprobe -r drbd)
  3. Load the updated drbd module (modprobe drbd)
  4. Restart any services that make use of the drbd module

A system reboot will also cause the updated module to be used.

Fixed in:

Debian GNU/Linux 5.0 (lenny)

Architecture-independent component:
HP Precision:
Intel IA-32:
Intel IA-64:
Big-endian MIPS:
Little-endian MIPS:
IBM S/390:
Sun Sparc:

MD5 checksums of the listed files are available in the original advisory.