Рекомендация Debian по безопасности

DSA-2022-1 mediawiki -- несколько уязвимостей

Дата сообщения:
23.03.2010
Затронутые пакеты:
mediawiki
Уязвим:
Да
Ссылки на базы данных по безопасности:
На данный момент ссылки на внешние базы данных по безопасности отсутствуют.
Более подробная информация:

В mediawiki, веб-движке для вики, было обнаружено несколько уязвимостей. Были определены следующие проблемы:

  • Недостаточная очистка входных данных в коде проверки CSS позволяет редакторам отображать внешние изображения на вики-страницах. Это может вызывать проблемы конфиденциальности на публичных вики, так как это позволяет злоумышленникам собирать IP адреса и другую информацию, оставляя ссылки на изображения на своём веб-сервере.

  • Недостаточные проверки прав доступа были обнаружены в thump.php, которые могут приводить к раскрытию файлов изображений, для которых установлены ограничения для определённы пользователей (например, при помощи img_auth.php).

В стабильном выпуске (lenny) эти проблемы были исправлены в версии 1.12.0-2lenny4.

В тестируемом выпуске (squeeze) эти проблемы были исправлены в версии 1:1.15.2-1.

В нестабильном выпуске (sid) эти проблемы были исправлены в версии 1:1.15.2-1.

Исправлено в:

Debian GNU/Linux 5.0 (lenny)

Исходный код:
http://security.debian.org/pool/updates/main/m/mediawiki/mediawiki_1.12.0-2lenny4.dsc
http://security.debian.org/pool/updates/main/m/mediawiki/mediawiki_1.12.0.orig.tar.gz
http://security.debian.org/pool/updates/main/m/mediawiki/mediawiki_1.12.0-2lenny4.diff.gz
Независимые от архитектуры компоненты:
http://security.debian.org/pool/updates/main/m/mediawiki/mediawiki_1.12.0-2lenny4_all.deb
Alpha:
http://security.debian.org/pool/updates/main/m/mediawiki/mediawiki-math_1.12.0-2lenny4_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/m/mediawiki/mediawiki-math_1.12.0-2lenny4_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/m/mediawiki/mediawiki-math_1.12.0-2lenny4_arm.deb
ARM EABI:
http://security.debian.org/pool/updates/main/m/mediawiki/mediawiki-math_1.12.0-2lenny4_armel.deb
HP Precision:
http://security.debian.org/pool/updates/main/m/mediawiki/mediawiki-math_1.12.0-2lenny4_hppa.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/m/mediawiki/mediawiki-math_1.12.0-2lenny4_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/m/mediawiki/mediawiki-math_1.12.0-2lenny4_ia64.deb
Little-endian MIPS:
http://security.debian.org/pool/updates/main/m/mediawiki/mediawiki-math_1.12.0-2lenny4_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/m/mediawiki/mediawiki-math_1.12.0-2lenny4_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/m/mediawiki/mediawiki-math_1.12.0-2lenny4_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/m/mediawiki/mediawiki-math_1.12.0-2lenny4_sparc.deb

Контрольные суммы MD5 этих файлов доступны в исходном сообщении.