Debian セキュリティ勧告

DSA-2039-1 cacti -- 入力のサニタイズ漏れ

報告日時:
2010-04-23
影響を受けるパッケージ:
cacti
危険性:
あり
参考セキュリティデータベース:
Debian バグ追跡システム: バグ 578909.
詳細:

システムとサービスのモニタリングツール rrdtool のフロントエンド cacti にサニタイズ漏れがあり、SQL インジェクション攻撃を許すことが 発見されました。

安定版 (stable) ディストリビューション (lenny) では、この問題はバー ジョン 0.8.7b-2.1+lenny2 で修正されています。

不安定版 (unstable) ディストリビューション (sid) では、この問題は近 く修正予定です。

直ぐに cacti パッケージをアップグレードすることを勧めます。

修正:

Debian GNU/Linux 5.0 (lenny)

ソース:
http://security.debian.org/pool/updates/main/c/cacti/cacti_0.8.7b-2.1+lenny2.diff.gz
http://security.debian.org/pool/updates/main/c/cacti/cacti_0.8.7b.orig.tar.gz
http://security.debian.org/pool/updates/main/c/cacti/cacti_0.8.7b-2.1+lenny2.dsc
アーキテクチャ非依存コンポーネント:
http://security.debian.org/pool/updates/main/c/cacti/cacti_0.8.7b-2.1+lenny2_all.deb

一覧にあるファイルの MD5 チェックサムは勧告の原文にあります。