Debian セキュリティ勧告

DSA-2334-1 mahara -- 複数の脆弱性

報告日時:
2011-11-04
影響を受けるパッケージ:
mahara
危険性:
あり
参考セキュリティデータベース:
Mitre の CVE 辞書: CVE-2011-2771, CVE-2011-2772, CVE-2011-2773.
詳細:

複数の欠陥が、電子ポートフォリオ、ウェブログ、履歴書作成システ Mahara に発見されました。

  • CVE-2011-2771

    Teemu Vesala さんにより、RSS フィードに入力のサニタイズが漏れてい るため、クロスサイトスクリプティング攻撃に繋がることが発見されまし た。

  • CVE-2011-2772

    Richard Mansfield さんにより、アップロードの制限が不十分なため、サ ービス拒否攻撃を許すという欠陥が発見されました。

  • CVE-2011-2773

    Richard Mansfield さんにより、団体管理にクロスサイトリクエストフォ ージェリを許す欠陥が発見されました。

  • (CVE ID はまだありません)

    Andrew Nichols さんにより、MNet 処理に特権の昇格を許す欠陥が発見さ れました。

旧安定版 (oldstable) ディストリビューション (lenny) では、この問題は バージョン 1.0.4-4+lenny11 で修正されています。

安定版 (stable) ディストリビューション (squeeze) では、この問題はバー ジョン 1.2.6-2+squeeze3 で修正されています。

不安定版 (unstable) ディストリビューション (sid) では、この問題はバー ジョン 1.4.1-1 で修正されています。

直ぐに mahara パッケージをアップグレードすることを勧めます。