Рекомендация Debian по безопасности

DSA-2344-1 python-django-piston -- уязвимость десериализации

Дата сообщения:
11.11.2011
Затронутые пакеты:
python-django-piston
Уязвим:
Да
Ссылки на базы данных по безопасности:
В системе отслеживания ошибок Debian: Ошибка 647315.
В каталоге Mitre CVE: CVE-2011-4103.
Более подробная информация:

Было обнаружено, что инфраструктура Piston может выполнять десериализацию недоверенны данных YAML и Pickle, что может приводить к удалённому выполнению кода (CVE-2011-4103).

В предыдущем стабильном выпуске (lenny) пакет python-django-piston отсутствует.

В стабильном выпуске (squeeze) эта проблема была исправлена в версии 0.2.2-1+squeeze1.

В тестируемом (wheezy) и нестабильном (sid) выпусках эта проблема была исправлена в версии 0.2.2-2.

Рекомендуется обновить пакеты python-django-piston.