Рекомендация Debian по безопасности

DSA-2521-1 libxml2 -- переполнение целых чисел

Дата сообщения:
04.08.2012
Затронутые пакеты:
libxml2
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2012-2807.
Более подробная информация:

Эри Элда обнаружил несколько переполнений целых чисел в libxml, которые могут приводить к выполнению произвольного кода или отказу в обслуживании.

В стабильном выпуске (squeeze) эти проблемы были исправлены в версии 2.7.8.dfsg-2+squeeze5.

В тестируемом (wheezy) и нестабильном (sid) выпуска эта проблема была исправлена в версии 2.8.0+dfsg1-5.

Рекомендуется обновить пакеты libxml2.