Debian Security Advisory

DLA-109-1 libyaml-libyaml-perl -- LTS security update

Date Reported:
14 Dec 2014
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 771365.
In Mitre's CVE dictionary: CVE-2014-9130.
More information:

Jonathan Gray and Stanislaw Pitucha found an assertion failure in the way wrapped strings are parsed in LibYAML, a fast YAML 1.1 parser and emitter library. An attacker able to load specially crafted YAML input into an application using libyaml could cause the application to crash.

This update corrects this flaw in the copy that is embedded in the libyaml-libyaml-perl package.

For Debian 6 Squeeze, these issues have been fixed in libyaml-libyaml-perl version 0.33-1+squeeze4