Debian Security Advisory

DLA-121-1 jasper -- LTS security update

Date Reported:
22 Dec 2014
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2014-8137, CVE-2014-8138.
More information:

Jose Duart of the Google Security Team discovered a double free flaw (CVE-2014-8137) and a heap-based buffer overflow flaw (CVE-2014-8138) in JasPer, a library for manipulating JPEG-2000 files. A specially crafted file could cause an application using JasPer to crash or, possibly, execute arbitrary code.

For Debian 6 Squeeze, these issues have been fixed in jasper version 1.900.1-7+squeeze3